No announcement yet.

ntfrs replication errors

  • Filter
  • Time
  • Show
Clear All
new posts

  • ntfrs replication errors

    A while back I posted and figured out a lot of my problems, but I'm still encountering 1 issue that has yet to be resolved.

    On my main server, I am getting a "VerifyReferencesFailed" error:

    The system object reference (serverReference)

    CN=OLDRDASERVER,OU=Domain Controllers,DC=rdadomain,DC=local and

    backlink on CN=OLDRDASERVER,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=rdadomain,DC=loc al
    are correct.
    Some objects relating to the DC OLDRDASERVER have problems:
    [1] Problem: Missing Expected Value

    Base Object:

    CN=OLDRDASERVER,OU=Domain Controllers,DC=rdadomain,DC=local

    Base Object Description: "DC Account Object"

    Value Object Attribute Name: frsComputerReferenceBL

    Value Object Description: "SYSVOL FRS Member Object"

    Recommended Action: See Knowledge Base Article: Q312862

    [1] Problem: Missing Expected Value

    Base Object:

    CN=NTDS Settings,CN=OLDRDASERVER,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=rdadomain,DC=loc al

    Base Object Description: "DSA Object"

    Value Object Attribute Name: serverReferenceBL

    Value Object Description: "SYSVOL FRS Member Object"

    Recommended Action: See Knowledge Base Article: Q312862
    I've also noticed that in the registry I don't have any subfolders under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\NtFrs\Parameters\Cumulative Replica Sets. I'm suppose to have a folder that has "Burflags (dword)" and "Number of Partners (dword)".

    In the ntfrs debug file I am getting:
    FrsDsVerifyPromotionParent: 1192: 5592: S0: 14:26:06> :S: ERROR - DOMAIN SYSTEM VOLUME (SYSVOL SHARE) does not exist on OLDRDASERVER!
    <LOCAL_FrsRpcVerifyPromotionParent:1192: 1731: S0: 14:26:06> ++ ERROR - verifying set DOMAIN SYSTEM VOLUME (SYSVOL SHARE) on parent OLDRDASERVER; WStatus: ERROR_NOT_FOUND
    <SERVER_FrsRpcStartPromotionParent:1192: 1874: S0: 14:26:06> ++ ERROR - verify; WStatus: FRS_ERR_SYSVOL_POPULATE
    <FrsDsFindComputer: 3556: 8796: S2: 14:28:55> S: Computer FQDN is cn=oldrdaserver,ou=domain controllers,dc=rdadomain,dc=local
    <FrsDsFindComputer: 3556: 8802: S2: 14:28:55> S: Computer's dns name is oldrdaserver.rdadomain.local
    <FrsDsFindComputer: 3556: 8816: S2: 14:28:55> S: Settings reference is cn=ntds settings,cn=oldrdaserver,cn=servers,cn=default-first-site-name,cn=sites,cn=configuration,dc=rdadomain,dc=loc al
    <FrsDsGetSubscribers: 3556: 8273: S0: 14:28:55> S: ERROR - No Member Reference found on subscriber (cn=domain system volume (sysvol share),cn=ntfrs subscriptions,cn=oldrdaserver,ou=domain controllers,dc=rdadomain,dc=local). Skipping
    <FrsGetResourceStr: 3556: 1366: S0: 14:28:55> ERROR - Failed to LoadLibrary. WStatus: ERROR_MOD_NOT_FOUND
    I want to recreate the sysvol tree, but without being able to add the D4 for an authoritative state in registry, I have no idea what else I can do to fix this problem. I also don't know why all of this happened.

    Any suggestions on how to proceed to fix these issues would be helpful (and I have read through Microsoft's knowledge base and it was no help)