No announcement yet.

Don't have permissions to access terminal server

  • Filter
  • Time
  • Show
Clear All
new posts

  • Don't have permissions to access terminal server

    I upgraded to a new domain (migrating fron NT4 to 2003). Everything has gone perfectly now except one thing.

    I upgraded our terminal server to Windows 2003, and made it a part of the new domain.

    Now whenever I (or any user) tries to log in I get "To log on to this remote computer, you must have Terminal Server User Access permissions on this computer. By default, members of the Remote Desktop users group have these permissions. If you are not a member of the Remote Desktop Users Ggroup or another group that has these permissions, or if the Remote Dektop User group does not have these permissions, you must be granted these permissions manually".

    Problem is I am a member of remote desktop users group, I still can't login and can't find where to give these permissions...

    Thanks for your assistance.

  • #2
    Have a look at the following thread:
    Guy Teverovsky
    "Smith & Wesson - the original point and click interface"


    • #3
      Hmm, read through it checked everything.

      2 things come up:

      1: On the terminal server I can not edit the policy for allow log on through TS. Though listed is remote desktop users. I added my user account on the server (which shows on the second DS) but it doesn't show here. I added group policy editor but still can't change it. However I am indeed a member of the group Remote desktop users.

      2: And this might really be the crux of the problem. I went into AD users & computers. Selected my user ID and under account there is no option allow logon through TS. I might be looking in the wrong spot etc but I sure can't find it...


      P.S. I see nothing in the event viewer (of intrest at least).


      • #4
        Any ideas? I am really desperate to get this working again...


        • #5
          Hmm. So you _upgraded_, did not rebuild? The problem might be that the RDP Users Group has no permissions because of that. The group needs to have the user right "Allow Logon through Terminal Services". That's worth checking. And this server is not a DC, I assume?

          Also, if this server really is a Terminal Server (application mode!) you will need to doublecheck the licensing server. By default, it needs to run on a DC although you can change that.


          • #6
            Indeed I upgraded and didn't rebuild. Where do I set allow login through termianl server (as I mention I can't find where that is hiding).

            I set up a licensing server on the terminal server (which isn't a DC though I can make it one if you guys think I should). It isn't complaining about licensing.

            Perhaps I should completely disable the terminal server and then redo it? Is that what you mean by "rebuild" or format the thing?


            • #7
              Ok, guess I went to fast. A user right is set through group policy or local policy, and applicies to accounts that log on to the computers in scope of the policies.

              In your case a local policy will do for a quick test. So, open gpedit.msc and go to Computer Settings -> Windows Settings -> Security Settings -> User rights. There you will find the user rights.

              > It isn't complaining about licensing.

              It will, _if_ you are running in application mode, not admin mode.


              • #8
                Sorry guess I wasn't clear.

                Fine listed as allowed to login are both myself (specifically) and the remote users group. I still can't log in (nor can anyone else (even adminsitrator by the way).

                Licensing shouldn't be a problem as I have the license server setup (specifically defined to be the actual machine) and licenses installed.

                I still however can't connect with the same message.

                What I can't find is that multiple peaple have said make sure allow users to log on through terminal services is checked. I dcan't find this under the user properties...



                • #9

                  Well I am glad to report the problem is now solved...

                  It was actually very very simple.

                  In terminal services configuration I had to set the sessions (well session since it a simple setup) properties. There set permissions and add in the appropriate groups.

                  Now all is well with the Terminal Server.



                  • #10
                    Re: Don't have permissions to access terminal server

                    You really shouldn't have hijacked this thread with your question.

                    You've also posted the same question under the SBS forum.

                    Which is it?? Terminal Services or SBS???


                    • #11
                      Re: Don't have permissions to access terminal server

                      Hello to everybody..... I have same problem as he have. I followed the instruction but still I encounter the same error. Can you help me on this??

                      Appreciate your help.