Announcement

Collapse
No announcement yet.

Group membership lost after ADMT user account migration

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Group membership lost after ADMT user account migration

    Hello everyone,
    I have this problem:
    migrating users from an old 2003 domain to a new 2003 domain with ADMT, I successfully migrated all groups, some users and their computers.

    Today, migrating another batch of users with the ADMT tool, it happens that they do not maintain their group membership after the migration. (Of course groups have been migrated before).

    Everything worked fine until yesterday!
    No matter the options I choose, today migrated user accounts seem to lose all their groups (the only one they have is "Domain users" of course...)

    What happens?
    Someone can tell me please what is going wrong?

    Thanks a lot in advance.

    Axplains

  • #2
    Re: Group membership lost after ADMT user account migration

    did you pick the option in the migration wizard "update group membership"or maybe it is called "Fix group membership"?

    Comment


    • #3
      Re: Group membership lost after ADMT user account migration

      Yes, I chose "Fix users' group membership", and "migrate SIDs" of course.
      Same as before (it worked until yesterday).
      No matter what I do, migrated users have no group...

      Comment


      • #4
        Re: Group membership lost after ADMT user account migration

        I had noticed few times when I used the ADMT , that the admt sql DB gets screwed up and those are symptoms you mentioned happened to me as well.
        If you uninstall the ADMT and re install it back again the problem should be solved.
        But doing so I am not sure if you would lose the SID mapping history that could effect further migration that are based on previous objects that were migrated.
        what I would do, I would migrate all the users and then remigrate the groups , by running the group migration wizard again (without deleting the groups, just run the group migration wizard again) and pick only the Fix/update group membership" option and leaving the rest unchecked, that might reattach the members that were migrated.

        Comment


        • #5
          Re: Group membership lost after ADMT user account migration

          Thanks Akila,

          unfortunately, uninstalling and reinstalling ADMT did not change anything,
          what works is migrating users (they migrate keeping no group membership on the target)
          and then remigrating groups and "fixing the groups membership". Then, their groups appear.

          But of course I have to do this every time I have to migrate a user...
          no way for new migrated users to keep their groups, while it worked perfectly until yesterday...


          EDIT:

          I found this:

          http://forums.techarena.in/server-migration/1054529.htm

          It is probably my case, but i don't know how to perform a SQL repair of the ADMT database.
          The SQL server icon in the system tray says "not connected - \\" and there are no DB services to manage.
          In the OS services list, the service "SQLAgent$MS_ADMT" is stopped and if I try to start it
          it returns a message "...the service... started and than stopped... no work to do".
          Last edited by axplains; 2nd December 2008, 12:30.

          Comment


          • #6
            Re: Group membership lost after ADMT user account migration

            I am not an SQL person, so I can't help you out here.
            but use the solution I gave you of remigrating groups, it works then use it.
            there is no harm in remigrating Groups, do every user bunch you migrate.
            BTW - when I uninstalled the ADMT I also deleted the old DB files, since the UNINSTALL does not delete those.
            did you delete any leftovers ADMT files?

            Comment


            • #7
              Re: Group membership lost after ADMT user account migration

              Well no, I don't know where they are...

              Comment


              • #8
                Re: Group membership lost after ADMT user account migration

                c:\windows\admt

                Comment


                • #9
                  Re: Group membership lost after ADMT user account migration

                  Thanks a lot, I will try.

                  EDIT:
                  I tried uninstalling ADMT, deleting the DB files, reinstalling etc., but the process went the same way:
                  all is OK for the first batches of migrated users, until suddenly group membership stops working.
                  I think the only solution is remigrating groups for every batch of migrated users.
                  It does not seem "good" to me, anyway... it seems I am forced to that.

                  Thanks for your help.
                  Last edited by axplains; 2nd December 2008, 18:54.

                  Comment

                  Working...
                  X