Announcement

Collapse
No announcement yet.

Replication and DNS not functioning

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Replication and DNS not functioning

    Dears,

    This is first post in this forum.
    I am badly got this problem. My domain name is not resolving and its replication is not happening.

    ingeomaa01 has the ip 10.138.2.26
    additional domain ip is 10.138.2.6 no where exist

    how to recover from this problem

    DCdiag report for you

    Domain Controller Diagnosis
    Performing initial setup:
    Done gathering initial info.
    Doing initial required tests
    Testing server: Chennai\INGEOMAA01
    Starting test: Connectivity
    Although the Guid DNS name
    (10c5e7e3-f3b5-44fc-85aa-0058a2e52a5e._msdcs.GEO-LOGISTICS.com)
    resolved to the IP address (10.138.2.6), which could not be pinged,
    the server name (ingeomaa01.GEO-LOGISTICS.COM) resolved to the IP
    address (10.138.2.26) and could be pinged. Check that the IP address
    is registered correctly with the DNS server.
    ......................... INGEOMAA01 failed test Connectivity
    Doing primary tests
    Testing server: Chennai\INGEOMAA01
    Skipping all tests, because server INGEOMAA01 is
    not responding to directory service requests
    Running partition tests on : Schema
    Starting test: CrossRefValidation
    ......................... Schema passed test CrossRefValidation
    Starting test: CheckSDRefDom
    ......................... Schema passed test CheckSDRefDom
    Running partition tests on : Configuration
    Starting test: CrossRefValidation
    ......................... Configuration passed test CrossRefValidation
    Starting test: CheckSDRefDom
    ......................... Configuration passed test CheckSDRefDom
    Running partition tests on : GEO-LOGISTICS
    Starting test: CrossRefValidation
    ......................... GEO-LOGISTICS passed test CrossRefValidation
    Starting test: CheckSDRefDom
    ......................... GEO-LOGISTICS passed test CheckSDRefDom
    Running enterprise tests on : GEO-LOGISTICS.com
    Starting test: Intersite
    ......................... GEO-LOGISTICS.com passed test Intersite
    Starting test: FsmoCheck
    [INGEOADC] LDAP bind failed with error 8341,
    A directory service error has occurred..
    ......................... GEO-LOGISTICS.com passed test FsmoCheck
    C:\Program Files\Support Tools>

  • #2
    Re: Replication and DNS not functioning

    Can you post an "ipconfig /all > c:\ipconfig.txt" result please?
    What is the primary DNS for this server and how many DCs do you have in total?
    cheers
    Andy

    Please read this before you post:


    Quis custodiet ipsos custodes?

    Comment


    • #3
      Re: Replication and DNS not functioning

      Primary DNS is 10.138.2.26 only. Domain Controller is in 10.138.0.26.

      Windows IP Configuration
      Host Name . . . . . . . . . . . . : ingeomaa01
      Primary Dns Suffix . . . . . . . : GEO-LOGISTICS.COM
      Node Type . . . . . . . . . . . . : Hybrid
      IP Routing Enabled. . . . . . . . : No
      WINS Proxy Enabled. . . . . . . . : No
      DNS Suffix Search List. . . . . . : GEO-LOGISTICS.COM
      Ethernet adapter Local Area Connection:
      Connection-specific DNS Suffix . :
      Description . . . . . . . . . . . : Broadcom BCM5708C NetXtreme II GigE (NDIS VBD Client)
      Physical Address. . . . . . . . . : 00-1A-64-C2-D3-F2
      DHCP Enabled. . . . . . . . . . . : No
      IP Address. . . . . . . . . . . . : 10.138.2.26
      Subnet Mask . . . . . . . . . . . : 255.255.255.0
      Default Gateway . . . . . . . . . : 10.138.2.11
      DNS Servers . . . . . . . . . . . : 10.138.2.26
      10.138.0.26
      Last edited by rasalp; 19th September 2008, 16:09.

      Comment


      • #4
        Re: Replication and DNS not functioning

        Have you changed anything recently.

        Can you restart the netlogon service and wait a couple mins then run dcdiag again?

        This isn't correct either - can you check?
        Originally posted by rasalp View Post
        Primary DNS is 10.138.2.26 only. Domain Controller is in 10.138.0.26.
        Your subnet mask is /24 so wouldn't allow that.
        cheers
        Andy

        Please read this before you post:


        Quis custodiet ipsos custodes?

        Comment


        • #5
          Re: Replication and DNS not functioning

          No. Primary is same as we have given.
          Geo-logistics.com is in 10.138.0.26

          Comment


          • #6
            Re: Replication and DNS not functioning

            OK, I see, apologies.
            In that case I would change the primary DNS so it points to the 10.138.0.26 server and restart netlogon. This should register it correctly.
            Can you provide info on the sites/dc setup please.

            Generally a DC shouldn't look at itself for Primary DNS as when it boots DNS starts after AD and therefore the registrations can't always be performed.
            Are there any other DC's in this site?
            cheers
            Andy

            Please read this before you post:


            Quis custodiet ipsos custodes?

            Comment


            • #7
              Re: Replication and DNS not functioning

              Originally posted by AndyJG247 View Post
              OK, I see, apologies.
              In that case I would change the primary DNS so it points to the 10.138.0.26 server and restart netlogon. This should register it correctly.
              Can you provide info on the sites/dc setup please.

              Generally a DC shouldn't look at itself for Primary DNS as when it boots DNS starts after AD and therefore the registrations can't always be performed.
              Are there any other DC's in this site?
              BTW - just for clearing things out a bit, netlogon service is in charge of registering only SRV records and not glue/A-Records.
              for A-records/Glue Records registration , you should restart the DHCP client service.

              Comment


              • #8
                Re: Replication and DNS not functioning

                Ooops, thanks
                cheers
                Andy

                Please read this before you post:


                Quis custodiet ipsos custodes?

                Comment


                • #9
                  Re: Replication and DNS not functioning

                  Although the Guid DNS name
                  (10c5e7e3-f3b5-44fc-85aa-0058a2e52a5e._msdcs.GEO-LOGISTICS.com)
                  resolved to the IP address (10.138.2.6), which could not be pinged,
                  the server name (ingeomaa01.GEO-LOGISTICS.COM) resolved to the IP
                  address (10.138.2.26) and could be pinged. Check that the IP address
                  is registered correctly with the DNS server.
                  ......................... INGEOMAA01 failed test Connectivity

                  I need this 10.138.2.6 should be cleared.

                  Setting up 10.138.0.26 and restarting dhcp havent worked out.

                  Comment


                  • #10
                    Re: Replication and DNS not functioning

                    Do you have more than one NIC or IP address on the single NIC setup?
                    cheers
                    Andy

                    Please read this before you post:


                    Quis custodiet ipsos custodes?

                    Comment


                    • #11
                      Re: Replication and DNS not functioning

                      Ip address on single nic setup

                      Comment


                      • #12
                        Re: Replication and DNS not functioning

                        please run netdiag /fix and post after that the results of a netdiag.
                        Dough I know restarting the netlogon service and dhcp client should work also I rather go for netdiag.
                        It gives a lot more info.

                        Also is there anything in eventviewer which make sense for this?
                        Have you checked for any old DC's in AD by using ntdsutil?
                        Last edited by Dumber; 21st September 2008, 17:49.
                        Marcel
                        Technical Consultant
                        Netherlands
                        http://www.phetios.com
                        http://blog.nessus.nl

                        MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
                        "No matter how secure, there is always the human factor."

                        "Enjoy life today, tomorrow may never come."
                        "If you're going through hell, keep going. ~Winston Churchill"

                        Comment


                        • #13
                          Re: Replication and DNS not functioning

                          Microsoft Windows [Version 5.2.3790]
                          (C) Copyright 1985-2003 Microsoft Corp.
                          C:\Documents and Settings\maaitadmin>nslookup
                          Default Server: ingeomaa02.geo-logistics.com
                          Address: 10.138.2.26
                          >
                          C:\Documents and Settings\maaitadmin>netdiag /fix
                          ....................................
                          Computer Name: INGEOMAA01
                          DNS Host Name: ingeomaa01.GEO-LOGISTICS.COM
                          System info : Windows 2000 Server (Build 3790)
                          Processor : x86 Family 6 Model 23 Stepping 6, GenuineIntel
                          List of installed hotfixes :
                          KB924667-v2
                          KB925398_WMP64
                          KB925902
                          KB926122
                          KB927891
                          KB929123
                          KB930178
                          KB931784
                          KB932168
                          KB933729
                          KB933854
                          KB935839
                          KB935840
                          KB936021
                          KB936357
                          KB936782
                          KB938127
                          KB938464
                          KB941202
                          KB941569
                          KB941644
                          KB941693
                          KB942763
                          KB942830
                          KB942831
                          KB943055
                          KB943460
                          KB943485
                          KB944338
                          KB944653
                          KB945553
                          KB946026
                          KB947864
                          KB948496
                          KB948590
                          KB948881
                          KB949014
                          KB950759
                          KB950760
                          KB950762
                          KB950974
                          KB951066
                          KB951072-v2
                          KB951698
                          KB951746
                          KB951748
                          KB952954
                          KB953838
                          KB953839
                          Q147222

                          Netcard queries test . . . . . . . : Passed

                          Per interface results:
                          Adapter : Local Area Connection
                          Netcard queries test . . . : Passed
                          Host Name. . . . . . . . . : ingeomaa01
                          IP Address . . . . . . . . : 10.138.2.26
                          Subnet Mask. . . . . . . . : 255.255.255.0
                          Default Gateway. . . . . . : 10.138.2.11
                          Dns Servers. . . . . . . . : 10.138.2.26
                          10.138.0.26

                          AutoConfiguration results. . . . . . : Passed
                          Default gateway test . . . : Passed
                          NetBT name test. . . . . . : Passed
                          [WARNING] At least one of the <00> 'WorkStation Service', <03> 'Messeng
                          r Service', <20> 'WINS' names is missing.
                          WINS service test. . . . . : Skipped
                          There are no WINS servers configured for this interface.

                          Global results:

                          Domain membership test . . . . . . : Passed

                          NetBT transports test. . . . . . . : Passed
                          List of NetBt transports currently configured:
                          NetBT_Tcpip_{000E7204-F103-4AD9-8B7A-B21AE0DEF7EC}
                          1 NetBt transport currently configured.

                          Autonet address test . . . . . . . : Passed

                          IP loopback ping test. . . . . . . : Passed

                          Default gateway test . . . . . . . : Passed

                          NetBT name test. . . . . . . . . . : Passed
                          [WARNING] You don't have a single interface with the <00> 'WorkStation Serv
                          ce', <03> 'Messenger Service', <20> 'WINS' names defined.

                          Winsock test . . . . . . . . . . . : Passed

                          DNS test . . . . . . . . . . . . . : Passed
                          PASS - All the DNS entries for DC are registered on DNS server '10.138.2.26
                          and other DCs also have some of the names registered.

                          Redir and Browser test . . . . . . : Passed
                          List of NetBt transports currently bound to the Redir
                          NetBT_Tcpip_{000E7204-F103-4AD9-8B7A-B21AE0DEF7EC}
                          The redir is bound to 1 NetBt transport.
                          List of NetBt transports currently bound to the browser
                          NetBT_Tcpip_{000E7204-F103-4AD9-8B7A-B21AE0DEF7EC}
                          The browser is bound to 1 NetBt transport.

                          DC discovery test. . . . . . . . . : Passed

                          DC list test . . . . . . . . . . . : Passed

                          Trust relationship test. . . . . . : Failed
                          [FATAL] Secure channel to domain 'GEO-LOGISTICS' is broken. [ERROR_NO_TRUST
                          SAM_ACCOUNT]

                          Kerberos test. . . . . . . . . . . : Failed
                          [FATAL] Kerberos does not have a ticket for host/ingeomaa01.GEO-LOGISTI
                          S.COM.

                          LDAP test. . . . . . . . . . . . . : Passed
                          [WARNING] Failed to query SPN registration on DC 'ingeodel1.GEO-LOGISTICS.C
                          M'.
                          [WARNING] Failed to query SPN registration on DC 'ingeoadc.GEO-LOGISTICS.CO
                          '.
                          [WARNING] Failed to query SPN registration on DC 'ingeoptg1.GEO-LOGISTICS.C
                          M'.
                          [WARNING] Failed to query SPN registration on DC 'AGI_MUM_ADC.GEO-LOGISTICS
                          COM'.
                          [WARNING] Failed to query SPN registration on DC 'CHCOEAD1.GEO-LOGISTICS.CO
                          '.
                          [WARNING] Failed to query SPN registration on DC 'ingeodel11.GEO-LOGISTICS.
                          OM'.

                          Bindings test. . . . . . . . . . . : Passed

                          WAN configuration test . . . . . . : Skipped
                          No active remote access connections.

                          Modem diagnostics test . . . . . . : Passed
                          IP Security test . . . . . . . . . : Skipped
                          Note: run "netsh ipsec dynamic show /?" for more detailed information

                          The command completed successfully
                          C:\Documents and Settings\maaitadmin>

                          Comment


                          • #14
                            Re: Replication and DNS not functioning

                            is this still an issue ?

                            if so,

                            can you describe your layout.

                            1 forest, single domain ? any child domains ?

                            looks like you have a trust and kerberos issue on that box.

                            how about running:

                            nltest /verify:domain

                            you might need to reset that SC channel using NLTEST as well.

                            Kerberos - is time synch'd ? fire up kerbtray and take a look to see if kerb tickets are being issued for that server.

                            Comment

                            Working...
                            X