No announcement yet.

DSget user

  • Filter
  • Time
  • Show
Clear All
new posts

  • DSget user

    As part of our exiting users process I have to capture what groups the member belong s to.

    I believe that I should be using the DSget user command to get this information.

    The issues is when I am using the following syntax, I not get any error messages or result

    H:\>dsget user "CN=General\, Jack,OU=Users,OU=xxx,DC=xxx,DC=xxx" -memberof –expand

    Is there something that I am doing wrong?

  • #2
    Re: DSget user

    What's your OU structure? if "Users" is the default Users container it should be CN=Users not OU=Users


    • #3
      Re: DSget user

      Users is an OU within the companies OU - It isn't on of the default of OU's.

      I have also tried the following syntax too with the same results.

      PS H:\> dsquery user -name jack* | dsget user -memberof
      PS H:\>

      I have had another tech on a different network try both syntaxs and they work for them.

      They haven't seen this issue before either.


      • #4
        Re: DSget user


        do you have proper access to active directory? your command line is correct.

        the other way round is getuserinfo from



        • #5
          Re: DSget user

          version of dsget? try running it on a dc.


          • #6
            Re: DSget user

            I have used accounts with Domain or Enterprise,

            The version of dsget i am using is 5.2.3790.0 - have tried running it from a desktop, member server and a DC and the same results.

            I am just not sure what to do next - i have a vb script that will do it but i not want to use it within the PS script