No announcement yet.

join domain error, maybe trust error?

  • Filter
  • Time
  • Show
Clear All
new posts

  • join domain error, maybe trust error?

    I have just reimaged an XP machine, tried to join to 2003 domain but when I type the domain admin username and password it errors saying something to the effect of: Computer name change error, ... couldnt join domain "name", bad username or password.

    First off, this image has worked with 30 other pc's so it shouldnt be a SID problem since its sysprep'd, am I correct. Also the username and password used has worked on previous and post joins when this computer errored, so it shouldnt be an account issue, im guessing.

    Now for the my trust theory. This computer was actually joined for testing within the same domain, but instead of removing it from the domain, I just imaged over it with this current image. When I checked the dc's event log, I noticed an error event id 5513, netlogon, "the computer <OldPcName> tried to connect to the server using the trust relationship established by the NCI domain. However, the computer lost the correct security identifier (SID) when the domain was reconfigured. Reestablish the trust relationship." Ive learned to remove a computer from now on.

    Is there a fix to this, when the computer has been imaged over before removing it from the domain and the OldPcName is no longer in ADUC? Ive tried dsquery and the old computer name does not show, Ive even tried sysinternals newsid and no luck.

    Thanks in advance, and let me know if more info is needed.

  • #2
    Re: join domain error, maybe trust error?

    reset the computer account in AD and try re-joining.
    Guy Teverovsky
    "Smith & Wesson - the original point and click interface"


    • #3
      Re: join domain error, maybe trust error?

      Thanks for the reply guyt, theres no account to reset. The old account the error message referred to is gone. I could be wrong about the trust relationship, this might have come up with another computer. The 5513 error was right about the time I imaged this particular pc, along with several others. But I just cant figure out why this one imaged pc will not join the domain. I rebooted the dc and the client, tried to join, and the error reappeared. But theres no failure audits or errors in the event logs of the dc or client. Ive even prestaged a computer account in aduc thats different from the errored name, and still no luck. Is there any other tool to let me know whats going on? Thanks again.


      • #4
        Re: join domain error, maybe trust error?

        Just an update. Of course I made things seem more difficult than they really were, but I spotted the problem. Instead of 10:49 AM it was 10:49 PM, so another simple error I overlooked.


        • #5
          Re: join domain error, maybe trust error?

          Dang time sync issues. That will get you every time and it's so easy to overlook.
          VCDX3 #34, VCDX4, VCDX5, VCAP4-DCA #14, VCAP4-DCD #35, VCAP5-DCD, VCPx4, vEXPERTx4, MCSEx3, MCSAx2, MCP, CCAx2, A+
 - VMware Virtualization Evangelist
          My advice has no warranties. Follow at your own risk.