No announcement yet.

RPC Server Unavailable Solution

  • Filter
  • Time
  • Show
Clear All
new posts

  • RPC Server Unavailable Solution

    There are a lot of posts as to how to fix the RPC Server Unavailable message when trying to join a domain. Most if not all are valid. However, one seems to have escaped everyone's notice, perhaps because it is a new issue.

    When I am using a Virtual Machine, Parallels to be specific, and the networking is set to use DHCP to obtain a network address, when I try to join the domain, the network adapter resets, resulting in one of two messages that either the domain could not be found or the RPC Server is unavailable.

    I am unsure whether this is an issue specific to Parallels and their bridged networking model, to all virtual machines, or to any computer using a foreign DHCP server (foreign to the domain that is). But what worked like a charm was setting a fixed IP address and then joining the domain.

  • #2
    Re: RPC Server Unavailable Solution

    Thanks for sharing how you solved your issue slylabs13.

    PS - Thread moved to Active Directory forum.

    Network Consultant/Engineer
    Baltimore - Washington area and beyond


    • #3
      Re: RPC Server Unavailable Solution

      Well Done!
      i was experiencing the same issue.
      i was simulating a dc with vmware, and could not join the domain.
      i did notice that the network did reset each time i tried.
      worked like a charm champ!

      Thanks heaps.