Announcement

Collapse
No announcement yet.

Home drives not mapping correctly

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Home drives not mapping correctly

    Last weekend I replaced an old W2K server with a 2003 Server and moved all the user shares to DFS shares. I also updated all users Home drive settings in AD Users and Computers, Profle tab, to point to the new locations. All the data copied over fine and NTFS permissions are the same as the original server.

    The problem I am having is our W2k and XP users home drives do not map correctly upon login

    After rebooting/powering on a PC and logging on the user has the wrong folder mapped to their U: drive. Here are the environment variables:
    HOMEDRIVE=U:
    HOMEPATH=\users\joeuser
    HOMESHARE=\\domain.lan\shares <- U: mapped to here, wrong!

    If I log off and then back on it works as it should, these are the environment variables:
    HOMEDRIVE=U:
    HOMEPATH=\ <- not sure about this?
    HOMESHARE=\\domain.lan\shares\users\joeuser <-correct!

    Tried turning on this GPO setting: Computer Configuration/Administrative Templates/System/Logon/Always wait for the network at computer startup and logon => enabled, then ran gpupdate /force on a client PC but it didn't help

    And this one too: Computer Configuration/Administrative Templates/System/Group Policy/Scripts Policy Processing => Enabled. Then, also checked "Allow processing across a slow network connection" just for kicks but that didn't work either

    Last MS KB article discusses this for NT & W2K, but no mention of XP SP2. As it is according to this it should work out of the box on W2K http://support.microsoft.com/kb/236813

    Thanks for any help
    Mike S

  • #2
    Re: Home drives not mapping correctly

    What happens if you manually disconnect the network drive and reboot?
    VCP on vSphere (4), MCITP:EA/DBA, MCTS:Blahblah

    Comment


    • #3
      Re: Home drives not mapping correctly

      Originally posted by gepeto View Post
      What happens if you manually disconnect the network drive and reboot?
      It connects to the wrong homeshare
      U: connects to \\domain.lan\shares
      HOMESHARE=\\domain.lan\shares

      Comment


      • #4
        Re: Home drives not mapping correctly

        Is it possible that a script is mapping the drive, not the setting in the user's AD account?
        VCP on vSphere (4), MCITP:EA/DBA, MCTS:Blahblah

        Comment


        • #5
          Re: Home drives not mapping correctly

          Originally posted by gepeto View Post
          Is it possible that a script is mapping the drive, not the setting in the user's AD account?

          No, the logon script is a one liner, just maps the M: drive to a common share

          Comment


          • #6
            Re: Home drives not mapping correctly

            If you login as a user who never had a profile on that box, does it do the same thing?
            VCP on vSphere (4), MCITP:EA/DBA, MCTS:Blahblah

            Comment


            • #7
              Re: Home drives not mapping correctly

              Originally posted by gepeto View Post
              If you login as a user who never had a profile on that box, does it do the same thing?
              Hey thanks for the replies!

              Good idea, so I made a new user and that account has the same problem. I also made a new user in an OU that does not have a GPO to make sure it wasn't a GPO problem and that account has the problem as well
              Mike

              Comment


              • #8
                Re: Home drives not mapping correctly

                is it in logon script?


                try to disconnect mapped drives on logon and then reconnected -- in logon.bat .. just modify the script and add to user profile to use ..

                -------------------------------------------------------------
                .
                .
                .

                net use * /delete ( it will disconnect all mapped drives)

                net use U: "\\SERVER\Share\%username%" ( reconnects the user's share)

                -------------------------------------------------------------

                use the %username% instead user's real name it will map to user folder in the shares folder

                besides what is the error code ? 64?

                Comment


                • #9
                  Re: Home drives not mapping correctly

                  Originally posted by abakus View Post
                  is it in logon script?


                  try to disconnect mapped drives on logon and then reconnected -- in logon.bat .. just modify the script and add to user profile to use ..

                  -------------------------------------------------------------
                  .
                  .
                  .

                  net use * /delete ( it will disconnect all mapped drives)

                  net use U: "\\SERVER\Share\%username%" ( reconnects the user's share)

                  -------------------------------------------------------------

                  use the %username% instead user's real name it will map to user folder in the shares folder

                  besides what is the error code ? 64?
                  Thanks for the reply. To get back to your questions

                  No it's not in the logon script and I tried setting it there but had mixed results

                  When I tried the net use "u: /delete" with the Home folder set in the Profile to the U: drive the logon script stopped stating the drive was in use and waited for a Y/N to continue. And it didn't get the Home folder to the right .

                  If you clear the Home folder setting by setting it to use Local the %home...% variables point the C:\ and the users Documents and Settings folder

                  Comment


                  • #10
                    Re: Home drives not mapping correctly

                    I have had problems with user home drives on DFS.
                    Try mapping to an individual server and see if that works:
                    net use U: \\server\users\%username%

                    Then use DFS to backup that server
                    Tom Jones
                    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
                    PhD, MSc, FIAP, MIITT
                    IT Trainer / Consultant
                    Ossian Ltd
                    Scotland

                    ** Remember to give credit where credit is due and leave reputation points where appropriate **

                    Comment


                    • #11
                      Re: Home drives not mapping correctly

                      Originally posted by Ossian View Post
                      I have had problems with user home drives on DFS.
                      Try mapping to an individual server and see if that works:
                      net use U: \\server\users\%username%

                      Then use DFS to backup that server
                      Yes I've tried that and the U: drive works that way. What's odd about that way is the other drives mapped by the logon script won't map a drive, turns out "net use" won't map a DFS deep root path e.g. \\doman\namespace\departments\dept. But if I set the Home folder U: drive to a deep root DFS path the logon script maps the other shared drives correctly but the U: is messed up! How whacky is that?

                      The reason I don't want to use SMB shares is when people travel to our other location and try to login in they will be opening all their files across the WAN instead off the local DFS server. Another is I had want users using the DFS paths/names and get a away from SMB shares.

                      I've got some funky AD or GPO issue going on, this should be working, our Terminal Server logins work fine, just the XP and W2K machines have this problem

                      Comment

                      Working...
                      X