No announcement yet.

Active Directory Object could not be displayed

  • Filter
  • Time
  • Show
Clear All
new posts

  • Active Directory Object could not be displayed

    A user object in my Active Directory is showing up as UNKNOWN. I am unable to view its propertise etc. Seems like the object is corrupt or something. Don't know how to go about resolving, need help!

    Additionally, the message "Unable to view attribute or value. You may not have permission to view object" comes up as well.

  • #2
    Re: Active Directory Object could not be displayed

    This behavior occurs if the account that you are logged on with has only "list contents" permissions on the parent object.
    Under this scenario, you are unable to read any attributes of the object, even though you can see the object. This prevents Windows from providing information about the object based on the objectClass attribute, such as the icon attribute. You also do not have permissions to perform any operations on the object, such as a Delete command, that requires access to the objectGUID.

    If you are a member of the local Administrators group on the domain controller, you may take ownership of the object and then grant yourself whatever access rights that you require.

    Try this;
    Logon on the DC with an account that is member of the 'Domain Admins' group
    (the 'Domain Admins' group is by default a member of the Administrators group on the DC. To check this, on the DC, click Start / Run and type: CMD /k net localgroup Administrators)

    - Open active directory users and computers
    - Click View on the menubar
    - check "Advanced Features"
    - Goto the UNKNOWN object and open the properties
    - on tab "Security" click on the 'Advanced' button.
    - Goto tab 'Owner'
    - Change Owner to the the administrator account that you are currently logged on with.
    - In the Security dialog box, assign Full Control permissions to your account.


    This posting is provided "AS IS" with no warranties, and confers no rights.


    ** Remember to give credit where credit's due **
    and leave Reputation Points for meaningful posts


    • #3
      Re: Active Directory Object could not be displayed

      Thanks REMS, I did what you suggested. However I'm still unable to get into the full functionality of the object's properties menu. I thought after I completed these steps, the user's status would change from UNKOWN to USERS allowing me to toggle through the various options for that user. I there something else I should be doing, thanks in advance.


      • #4
        Re: Active Directory Object could not be displayed

        I too am having the same issue, but my object that can't be displayed is the "Domain Users". As you can imagine, this is a bit of a problem. I have tried Rems solution and taken ownership of the group, but still no luck. Im beginning to wonder if it is corrupt or something? Is there anyway to re-instate these system based security groups? Any information greatly appreciated, cheers.