Announcement

Collapse
No announcement yet.

REMOVING NTFS PROTECTED FILES

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • REMOVING NTFS PROTECTED FILES

    I have recently came upon this problem: I can't delete some of documents and settings files, of users from previous installation of windows XP ( my previous and current OS) - an error occurs no matter what i try - access denied. And when i use recovery console and temporarily gain access i can't delete them all because there are over 1000 subfolders and i can't use del /s to delete all files because arguments don't work. I need those folders deleted cause they take a lot of space. Is there some way to either activate the arguments for dos functions (enabling some service or driver ?) or a program that could dispose them for me?

  • #2
    I am stating the obvious because it hasn't been, but have you logged on as Administrator and tried Taking Ownership of the folders and files?
    1 1 was a racehorse.
    2 2 was 1 2.
    1 1 1 1 race 1 day,
    2 2 1 1 2

    Comment


    • #3
      I wish it were that easy biggles77. The problem is that files were given protection by user with adminstrator rights (so no one else could browse his folders), in the previous installation of Win XP. Recently a bug occured and i made a mistake, which led to complete re-installation of win XP (without formating the drive). This means that the files are protected by/for a user who doesn't exist in current installation of XP (noone to take rights from). As i wrote the problem is not accessing the files ( I can do so with NTFSreader, or via Recovery console), nor their deletion were there only few files and folders. The problem is that deleting (without /s argument) over 8000 files in over 1000 folders, folder by folder, seems very unaatractive. Therefore my question is if there is some freeware or shareware program that could delete them, or a driver or service i have to enable for the arguments of 'del' and 'rd' (removing directory) dos-functions to work?

      Hope everything, including solution , is clear now.

      Comment


      • #4
        1) take ownership of the directories recursively
        2) change the permissions on the folders (if you do not like GUI, you can use cacls.exe or xcacls.exe to give yourself full control over the files)
        3) delete the directories
        Guy Teverovsky
        "Smith & Wesson - the original point and click interface"

        Comment


        • #5
          Thanks Guy. Aad sorry biggles77. That was the right way. Taking ownership was quite easy. It seems i wasn't looking carefully enough to notice the right option in foldersettings->view (tab) to notice how i can enable security tab in properities. Once that was done it was a short work. Thanks again.

          Comment


          • #6
            No need to be sorry, you have just gained some valuable experience and that is something money cannot buy.

            Well done on finding out where it went wrong and correcting it!
            1 1 was a racehorse.
            2 2 was 1 2.
            1 1 1 1 race 1 day,
            2 2 1 1 2

            Comment


            • #7
              Re: REMOVING NTFS PROTECTED FILES

              I have exactly the same problem except I am using Home ed. I don't see any way to change file attributes or permissions as described above. Is there another way? I have tried a file deletion tool be SecureClean, but it soesn't do it. There are 7 .iso files involved so there is quite a bit of disk space wasted.

              Comment


              • #8
                Re: REMOVING NTFS PROTECTED FILES

                eingram

                on win xp home this option is hidden,
                i had to do this on a friends computer a few months back,
                you have to restart the machine in safe mode,
                open my computer
                go to tools > folder options
                click on the view tab
                scroll down to the bottom untick use simple file sharing,

                still in safe mode,
                go to the files/folders concerned
                take ownership/delete what ever you need to
                restart

                Comment

                Working...
                X