Announcement

Collapse
No announcement yet.

Not able to deploy software via GPO

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Not able to deploy software via GPO

    Hi,
    This is my first post here and I really appreciate if someone can help me with the issue that I have come across.

    Goal: to distribute software to multiple windows XP Pro SP2 machines using AD GPMC tool.

    I have created a test OU and placed there a test machine which is part of the domain. Then created a test GPO and linked it to the OU where that test computer resides. Then edited it and applied new software.msi package to it - assigned.
    Manualy refreshed DC and the test computer. Restarted test PC - software did not install. Below is the error message:

    The install of "application Name" from policy "Policy Name" failed. The error was : The installation source for this product is not available. Verify that the source exists and that you can access it.

    Software is located under Sysvol ->scripts default DC share. Also tried to create a separate softdistr folder on the network share - with no luck - the test machine will not get this application installed.
    I am able to access it there is no issue with that.

    Any ideas? Please help.

    Thanks
    Regards,
    John

  • #2
    Re: Not able to deploy software via GPO

    Can you post step by step what you did, my guess is the GPO was setup incorrectly. you also need to take note of Publishing and Assigning software.

    If you are interested here is a good article regarding this:

    http://www.windowsnetworking.com/art...lications.html
    Technology is only as good as those who use it

    My tech blog - wiredtek.wordpress.com

    Comment


    • #3
      Re: Not able to deploy software via GPO

      Thanks for your reply and the link wiredteknologies....

      It's ironical, but like 10 minutes after I posted into forums I was able to figure this out.
      What I did was:

      * created a new folder for softw. distr. point under \\servername\netlogon default share
      * moved software.msi package to it
      * from GPMC tool navigated to that location via "My Network Places" instead of going thru \\servername\netshare location
      * manually forced refresh - restarted test machine and it worked like a charm...

      So I guess it was not able to access the source location for this package for some reason...
      Regards,
      John

      Comment


      • #4
        Re: Not able to deploy software via GPO

        In the software deployment policy you have to use an UNC path (example \\servername\sdp$).
        You can not use a local path (example:c:\sdp\spd$)
        [Powershell]
        Start-DayDream
        Set-Location Malibu Beach
        Get-Drink
        Lay-Back
        Start-Sleep
        ....
        Wake-Up!
        Resume-Service
        Write-Warning
        [/Powershell]

        BLOG: Therealshrimp.blogspot.com

        Comment


        • #5
          Re: Not able to deploy software via GPO

          Thanks for your reply Killerbe....

          First I have used the default Sysvol\Scripts folder on our DC to store the .msi package. Even it's located under the system drive, I thought that it still should work, since that's where machines are getting there net drives mapping info etc.

          I am still using the same SPD on the sysvol share and it's working fine. The only thing that I did differentlly - when I go to select package from GPMC tool I go thru the "My network Places" and then navigate to that share.
          Regards,
          John

          Comment


          • #6
            Re: Not able to deploy software via GPO

            Originally posted by John777 View Post
            Thanks for your reply Killerbe....

            First I have used the default Sysvol\Scripts folder on our DC to store the .msi package. Even it's located under the system drive, I thought that it still should work, since that's where machines are getting there net drives mapping info etc.

            I am still using the same SPD on the sysvol share and it's working fine. The only thing that I did differentlly - when I go to select package from GPMC tool I go thru the "My network Places" and then navigate to that share.
            So the path of the source package changed from C:\Windows\Sysvol\Sysvol to a UNC path \\servername\share.
            [Powershell]
            Start-DayDream
            Set-Location Malibu Beach
            Get-Drink
            Lay-Back
            Start-Sleep
            ....
            Wake-Up!
            Resume-Service
            Write-Warning
            [/Powershell]

            BLOG: Therealshrimp.blogspot.com

            Comment


            • #7
              Re: Not able to deploy software via GPO

              Yes, that's correct. Thanks
              Regards,
              John

              Comment

              Working...
              X