Announcement

Collapse
No announcement yet.

Remove a Domain-based DFS root manually?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Remove a Domain-based DFS root manually?

    After creating our first Domain-based DFS root which I believed would be replicated throughout the AD, the machine housing the root crashed. The hard drive crashed and was unrecoverable. Since then the machine was rebuilt and put back on line with the same name and all. The AD still sees the old DFS root and would not let me create a new root with the same name. Is there a way to manually remove the info in AD that holds the Domain-DFS roots since the machine that held that root is now out of service (at least as far as AD is concerned)?

    Everything I have tried using dfsutil has failed because it tries to contact the former root server and the DFS mmc can't delete it because it says the root doesn't exist...

    Any thoughts?

    I have created a new root already and it works just fine, but I'd like to remove the old root for tidyness' sake... I have also created another root target for this root in case 1 machine bites the dust as before.

  • #2
    Have you performed metadata cleanup after the server crash and before installing the DC with the same name ?
    Guy Teverovsky
    "Smith & Wesson - the original point and click interface"

    Comment


    • #3
      metadata cleanup

      I did some manual cleanup in dns and stuff so that I could put that server back online and promote it to dc... After doing cleanup, the server was not listed but the DFS root was still attached to the domain...

      Comment


      • #4
        I can only guess, but I would almost bet you currently have some nusty collisions in AD.

        Take a look here:
        http://support.microsoft.com/default...b;en-us;216498
        Guy Teverovsky
        "Smith & Wesson - the original point and click interface"

        Comment


        • #5
          I do remember using the ntdsutil and adsiedit to remove the AD info for the old server... What I need to find out though is where the info for the Domain-DFS roots is held in AD so that I can delete. I thought it would be deleted with the computer account info or the DNS info... but it's not. Are the Domain-DFS roots' information stored in the SYSVOL share? And could they be delete without screwing up the AD altogether?

          There must be a folder/containter somewhere in the AD that holds the Domain-DFS root listings. I will keep searching...

          Comment


          • #6
            I noticed you've already tried dfsutil to remove or cleanup dead links, I assume you've already tried ( /RemFtRoot, /UnmapFtRoot, /clean) so...
            using ADSI Edit try looking at:

            DC=YOURDOMAIN, CN=System, CN=Dfs-Configuration, where yourdomain is the domain where the DFS root was created before.
            Andrew

            ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

            Comment


            • #7
              Andrew... you're a freaking genius.

              Thank you, that was the fix. I removed the entry for the root and the entry for the frs volume and that fixed it.

              And good luck with hurricane charley, my family's down there too...

              Tim Fort
              A+ 2004

              Comment


              • #8
                DIFFERENT.APPROACH.

                Hi Tim,
                I got into the same problem like you. I played with it by creating some DFS roots. And after I removed those roots I still saw them when I browse to my domain DFS. So I came here and read the post. I followed Andrew's instruction but I didn't see anything that I can edit in that DFS-Configuration. So I went to the DC and did net share and saw whole bunch of shares that I created. I delete all of those share and then come back to the browser and those obsolete roots are gone now. I just want to let you know of another solution. I'm kinda happy because I've been spending two freaking days to figure out what caused the problem

                Regards,
                Teamwork

                Comment

                Working...
                X