Announcement

Collapse
No announcement yet.

SQL 2008 Constraints / Default values just not working...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SQL 2008 Constraints / Default values just not working...

    Hey guys,

    Been struggling with this all afternoon... I'm currently trying to learn SQL, my test database was getting rather messy so I decided to delete it, no problem there, re created the tables, fields, constraints and triggers, all looking good... Its just non of the constraints work... Am I missing something, is there a command I have to run to enable them....?? I don't get how I managed to set it up last time but this time I just cant.....

    Any help/pointers most welcome

    Thanks

    Dave

  • #2
    Re: SQL 2008 Constraints / Default values just not working...

    Double check:
    http://blog.sqlauthority.com/2009/11...ck-constraint/
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: SQL 2008 Constraints / Default values just not working...

      Hey,

      Thanks for that, looks like it's sorted...

      For some reason (suser_sname()) which worked fine for well over a week decided it didn't want to work any more, changed it to (user_name()) and it seems to like that... rather odd really....

      Thanks

      Dave

      Comment

      Working...
      X