No announcement yet.

Error 17055 when attempting ALTER DATABASE

  • Filter
  • Time
  • Show
Clear All
new posts

  • Error 17055 when attempting ALTER DATABASE

    Current SQL install: Sql Server 2000 DE sp2
    Problem: Database can't be altered or shrunk

    1827 :
    CREATE/ALTER DATABASE failed because the resulting cumulative
    database size would exceed your licensed limit of 2048 MB per database.
    This has been driving me loony. All I hear from the interwebs is to upgrade to sql server 2005 express. When I attempt the upgrade, I get the same error message! I wanted to shrink or purge the database so I could start using it again, but it appears I can't do anything to shrink because it's already at its size limit!

    Moving the database, fixing it, then moving it back could be an option... any advice on how to do that?

    I will attempt to provide more information once I've calmed down.

    Any advice on what to do and possibly how to do it for this SQL idiot will be greatly appreciated.
    Last edited by Parkham; 16th October 2012, 15:20.

  • #2
    Re: Error 17055 when attempting ALTER DATABASE

    IMHO Detach db,, install new database engine (2008R2 better than 2005) and attach db

    But I do not know what is in the db or if this will cause issues
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    IT Trainer / Consultant
    Ossian Ltd

    ** Remember to give credit where credit is due and leave reputation points where appropriate **


    • #3
      Re: Error 17055 when attempting ALTER DATABASE

      In between, I figured out how to detach the db. running into trouble upgrading to sql 2005 express though. I get this error:

      Event ID 19011
      SuperSocket info: ConnectionListen(Shared-Memory (LPC)) : Error 5.
      Googling suggests that I do this (didn't work)
      Copy the BPAClient.dll file from the following location
      C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\BPA\bin
      to C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\BPA.
      and to do this:

      To work around this problem, turn off the shared memory protocol on
      the computer that is running SQL Server Service Pack 3 (SP3). To do this,
      follow these steps.
      Click Start, point to Programs, point to Microsoft SQL Server, and then click Client Network Utility.
      In the SQL Server Client Network Utility dialog box, click the General tab.
      Click to clear the Enable shared memory protocol check box, and then click OK.
      But I can't figure out to do that because I don't have a gui and couldn't find an osql reference..

      Right now I'm upgrading from sp2 to sp4 and then try the sql 2005 express upgrade. Thanks for looking at this.


      • #4
        Re: Error 17055 when attempting ALTER DATABASE

        OK. I'm just an idiot. I got the Named Instance misspelled when upgrading.

        Now to figure out how to reattach the detached database without EskerFax blowing up on me. Got my information from here:

        use master
          sp_attach_db 'mydb','E:\Sqldata\mydbdata.mdf','E:\Sqldata\mydblog.ldf'
        Verify the change in file locations by using the sp_helpfile stored procedure:
        use mydb
        Any suggestions?
        Last edited by Parkham; 16th October 2012, 17:28.


        • #5
          Re: Error 17055 when attempting ALTER DATABASE

          I'm back to square one.

          grrrr.. When I attach the database with osql, it won't work. When I try it with SQL server studio it fails too. The error messages are the same.

          Could not allocate space for object 'alerts' in database 'Reporting' because the 'DEFAULT' filegroup is full.
          Error while undoing logged operation in database 'Reporting'.  Error at log ID (182223:496:40).
          Could not open new database 'Reporting' CREATE DATABASE is aborted.
          191 transactions rolled forward in database 'Reporting' (8). (Microsoft SQL Server, 
          Error: 1105)