Announcement

Collapse
No announcement yet.

Running report created in Report Server comes up with an error (details in body of po

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Running report created in Report Server comes up with an error (details in body of po

    I have inherited an environment and users have reported an error with certain reports on a Sharepoint site. The reports were created in SQL Server and published to a Sharepoint site for the ease of end users.

    The error reported is:

    An error occurred during client rendering.
    An error has occurred during report processing.
    Query execution failed for dataset 'datasetname'.
    For more information about this error navigate to the report server on the local server machine, or enable remote errors.
    I have been searching online for a solid week now in Google but nada.
    The datasource related to this report is a shared data source.
    I have changed the type of credentials that would be used by the report server to access this report data source but I get the same message.
    I went from windows authentication (integrated) to using stored credentials (I have full admin rights).
    I have enabled the data source of course.
    This, I am all managing via a webpage as set up by whoever designed the environment before.
    Report Server has been integrated with Sharepoint.
    I am truly stumped. Any help would be much appreciated.

  • #2
    Re: Running report created in Report Server comes up with an error (details in body o

    If you can get into the report definition, can you extract the query and run it against the actual SQL server?
    (I am wondering if something has changed at the database level which is causing the problem)

    When you test the data source connection, does it work?
    Last edited by Ossian; 4th July 2012, 17:46.
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: Running report created in Report Server comes up with an error (details in body o

      I am not able to do that. I am trying to open up the Business Intelligence Development Studio and point to the data source to open it up but I can't even find where this guy has stored it.

      Baby steps, please? Where do I start?

      Thanks,

      Phil

      Comment


      • #4
        Re: Running report created in Report Server comes up with an error (details in body o

        If you have admin access to the report server site, you should be able to "export report" (cannot remember exact wording) to a report definition, then open it in BIDS (add it to another project)

        From that you can extract the actual dataset queries and test them directly against SQL server
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd
        Scotland

        ** Remember to give credit where credit is due and leave reputation points where appropriate **

        Comment


        • #5
          Re: Running report created in Report Server comes up with an error (details in body o

          I cannot find the report. We have multiple servers, with a few mirror servers for testing. I have a very rough idea of where the report server may be installed on but I couldn't be sure. How would I go about checking for this? Can I do a search for the actual report files? I have tried the search function within each environment and come up with nothing.
          This issue has been a burden to me.

          Comment


          • #6
            Re: Running report created in Report Server comes up with an error (details in body o

            Sorry, I forgot you were sharepoint integrated, so the reports will be stored within Sharepoint, not as a separate site.

            You should have permission if you are an SP Admin to download the report as a definition file
            Tom Jones
            MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
            PhD, MSc, FIAP, MIITT
            IT Trainer / Consultant
            Ossian Ltd
            Scotland

            ** Remember to give credit where credit is due and leave reputation points where appropriate **

            Comment


            • #7
              Re: Running report created in Report Server comes up with an error (details in body o

              Download it from where? I have searched everywhere and I don't know where this guy has stored these files.
              Is there a query I can run against the server that can pull up names of data sources? I am searching against data sources even against working reports and I cannot find these listed anywhere against the ReportServer database.

              Thanks,

              Phil

              Comment


              • #8
                Re: Running report created in Report Server comes up with an error (details in body o

                The SharePoint reporting services site - the same place you run the report from
                Tom Jones
                MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
                PhD, MSc, FIAP, MIITT
                IT Trainer / Consultant
                Ossian Ltd
                Scotland

                ** Remember to give credit where credit is due and leave reputation points where appropriate **

                Comment


                • #9
                  Re: Running report created in Report Server comes up with an error (details in body o

                  I don't even get the option to enter in parameters, which means the report doesn't even launch before throwing up the errors. As soon as I click on the link from the user's workstation, I get the error:

                  An error has occurred during report processing. (rsProcessingAborted)
                  o Cannot create a connection to data source 'DataSourceName'. (rsErrorOpeningConnection)
                  For more information about this error navigate to the report server on the local server machine, or enable remote errors.

                  Report Server logs from the server show:

                  System.Data.SqlClient.SqlException: Setuser failed because of one of the following reasons: the database principal 'Domain\Philip' does not exist, its corresponding server principal does not have server access, this type of database principal cannot be impersonated, or you do not have permission.

                  It works for my workstation and my fellow admin's workstation but not others so I figure it must be a permissions issue but where can I check and change these permissions to allow the report to run?

                  I have been deep in Google but I am coming up with nothing.

                  Please help me .
                  Last edited by Philip; 10th July 2012, 21:45.

                  Comment


                  • #10
                    Re: Running report created in Report Server comes up with an error (details in body o

                    From the message you give above, you are not a SQL server user

                    Can you try as the domain admin?
                    Tom Jones
                    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
                    PhD, MSc, FIAP, MIITT
                    IT Trainer / Consultant
                    Ossian Ltd
                    Scotland

                    ** Remember to give credit where credit is due and leave reputation points where appropriate **

                    Comment

                    Working...
                    X