No announcement yet.

SQL Login Failure and search database

  • Filter
  • Time
  • Show
Clear All
new posts

  • SQL Login Failure and search database

    I had to change the admin password on our SBS 2008 server after a high level executive left the company. I thought I had found all the stuff that this effected but apparently I was wrong. After a reboot, the search service in sharepoint failed to start. I went to sharepoint/operations/services on the server/ put in the passwords for spsearch and spcontent and renamed the database. It still failed to start. I went to services and changed the login password for windows search service and it started. In sharepoint it showed the search service to still be down. So I went to SQL Server management studio express and I am unable to login in using windows authentication. It says login failure. I see it has my user name and password but it is using the password that I had before I changed it and it is greyed out and won't let me put in the correct password. I can't use sql authentication because I have no Idea what the sa password is. I don't remember setting a password for this when I setup the server. Can someone please help me with the greyed out problem so I can put in the correct password to login? Thanks

  • #2
    Re: SQL Login Failure and search database

    Ok I figured this out. After I restarted the sharepoint search service and gave the search database a new name, I went into the SQL Manager and detached the old search database. Apparently the old search database was the default database for my login. So after I detached it, my login quit working correctly.
    The fix was to click on options at the sql manager login screen and put in master as my default database. I was then able to login but I couldn't do anything. I kept getting login failure If I tried to look at properties of a database or a login. The fix for this was to run a sql statement that changed my default database.

    Be sure to use the domian\user format [with] these brackets.
    Here is a link to the fix. It worked like a champ!