Announcement

Collapse
No announcement yet.

Outlook(home) cant get mail from exchange server (at work)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Outlook(home) cant get mail from exchange server (at work)

    Hi all, I'm new to all the exchange thing. I have a server at my work place, with SBS2003, exchange is installed, we have a firewall.

    I made a Successful VPN connection to my Server and I can use remote, see folders, workstations and so on. The problem is that I cant connect My own Outlook at HOME to the exchange server at WORK to get my mail.

    how can I recive My mail from the exchange or the server or any thing that holds My mail????

    HELP!!!! thnx.

    p.s. I have admin right, and have all passwords and things i need.

  • #2
    Ensure there are no firewalls blocking RPC connections to your server.

    Then ensure you can ping the exchange server by the name you are typing in when setting up outlook.

    You could just use OWA which would be easier and quicker, and is setup by default.

    http://<servername>/exchange
    * Shamelessly mentioning "Don't forget to add reputation!"

    Comment


    • #3
      As topper already said, I have a feeling your name resolution isn't working.

      Get into command prompt, ping servername, most likely it will come back claiming that it can't, ping the IP of the server and that will probably work.

      If so, just edit your hosts file and put in

      server_ip servername

      save it and try again.

      Most common problem #2 would be the same subnet usage, but since you can access shares/see workstations you're probably fine (although once again I've seen some strange cases where that would work, but exchange wouldn't).

      Just for fun, run the ipconfig /all command on your pc at home and see what internal IP scheme you're using (such as 192.168.1.xxx) , if your work uses the same thing your VPN session would connect, but would not let you access any resources on their network

      Comment


      • #4
        thnx for all but still its not working

        when i use ipconfig /all at home i get the ip given to me by my isp.
        so in any case its not the same as the internal network ip at work

        also i can say that i have access to my outlook mail by https
        but its not what i need
        i want my own outlook 2003 program to work at home and see mail at work

        some say use "owa" but i heard that i need 2 servers???

        i need some thing to help me with a client cpu at home and a server at work.
        thnx all.

        Comment


        • #5
          by the way how can i know my exchange server name or ip
          if not i was the admin who set it up??
          is there any good command or way to detect it??

          Comment


          • #6
            Firstly youe don't NEED two servers for OWA but it is highly recommended. Your front server (no mailboxes) sits in your DMZ and talks to you backend server (where all your mailboxes live) but doesn't have any direct contact withe OWA user.

            OWA is installed by default on an exchange server (goto http://exchangeserver/exchange) If you make this server available to the outside world (ie not have a front end backend setup) then i would HIGHLY recommend not using port 80 (unsecure) and get HTTPS (ssl) setup.

            Secondly the method you are trying to get outlook to connect to your server is a very bad one. If you want to do what you are wanting then i would recommend using a VPN to your work and doing it that way. Much more secure if a bit slower.
            Server 2000 MCP
            Development: ASP, ASP.Net, PHP, VB, VB.Net, MySQL, MSSQL - Check out my blog http://tonyyeb.blogspot.com

            ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

            Comment


            • #7
              thank u again for ur patience.

              i installed a fire wall at work and made sure it is not the one who makes the problems.
              i have established a secured vpn connection from home to my work.

              now how i get the woa to work??
              is it built in outlook, and all i need is to operate it? or
              is it a command that i have to use?

              i filled in some data in properties of my outlook at home but im getting an error message. ill add a picture.




              Comment


              • #8
                Can you ping your exchange server by name as well as IP address?
                Server 2000 MCP
                Development: ASP, ASP.Net, PHP, VB, VB.Net, MySQL, MSSQL - Check out my blog http://tonyyeb.blogspot.com

                ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

                Comment


                • #9
                  The bit that puzzles me is you are trying to connect to an exchange server, (i.e. first picture), but on the 3rd picture the tests you are running are for an Internet Mail account.

                  Which one are you trying to use ?

                  Firstly, going on the error message in the 2nd picture, try disabling offline files, (i.e Untick "Use Cached Exchange Mode", shown in the 1st picture.)

                  Secondly if you want to use OWA (outlook web access), this is done by Internet Explorer not outlook. Open your browser and type http://192.168.**.**/exchange where the IP address is the internal LAN interface of your exchange server.

                  Hope this makes sense, and let us know if this works for you.

                  Topper.
                  * Shamelessly mentioning "Don't forget to add reputation!"

                  Comment


                  • #10
                    Yes that confused me too but i thought he was showing that it works by POP but not MAPI. Thats what made me think of DNS issues.
                    Server 2000 MCP
                    Development: ASP, ASP.Net, PHP, VB, VB.Net, MySQL, MSSQL - Check out my blog http://tonyyeb.blogspot.com

                    ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

                    Comment


                    • #11
                      re re hi.
                      first of all yes i can work with the WOA by https
                      this works just fine. but i want to use outlook not WOA.

                      about the dns problem there is a problem
                      i can ping my server at work with ip only but it can not resolve the servers name when i use ping -a +ip
                      more over if i ping the werver using its name which i know its not working. so maybe this is a start.

                      what is the next step?

                      thank u so much for the help.

                      Comment


                      • #12
                        Originally posted by topper
                        Firstly, going on the error message in the 2nd picture, try disabling offline files, (i.e Untick "Use Cached Exchange Mode", shown in the 1st picture.)
                        Have you tried this ? I don't think it's a name resolution issue because when you click "check name", then server name resolves and the Account resolves which means it's contacted your Exchange server fine.

                        Pinging with -a x.x.x.x runs a reverse lookup which is not actually needed in your setup.

                        Also make sure that in your MAPI profile you have the option "Automatically control connection state" ticked, and you are not running on manual.

                        Topper
                        * Shamelessly mentioning "Don't forget to add reputation!"

                        Comment


                        • #13
                          Yes but if you type in the IP address of the server what responds with the name? The server or DNS? If it is the server then any future connections will be by name and if DNS isn't working then it wont work.

                          Try adding your exchange server into your hosts file (c:\windows\system32\drivers\etc\hosts) just to eliminate DNS. Then try pinging your server (from home over you VPN) using both the IP address and the Name. Both need to work.
                          Server 2000 MCP
                          Development: ASP, ASP.Net, PHP, VB, VB.Net, MySQL, MSSQL - Check out my blog http://tonyyeb.blogspot.com

                          ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

                          Comment


                          • #14
                            ok 1 step is done and working now what next!!

                            Thank u both for your help again.
                            thnx for beeing so patience.

                            this time it worked. i added the server and its ip to the host list.
                            and than ping went all good. by name and by ip. dns problem is down.

                            i loaded again my outlook 2003 and filled in the details in the IMAP section. when i finished it promped me to fill in the servers password.

                            any account i used didnt worked out. when i use my admin pass and name its working just fine and i can get my mail.

                            the problem is how can a simple worker not an admin get in at same way
                            and not use my admin pass but his own pass. where do i set this pass for him???

                            thnx again.

                            Comment


                            • #15
                              i searched at the active directory and i dont see any place to allow a user to be a remote user or a mobile1.

                              i set some of our users as mobiles and still they cant use their mail with their own logon passwords.

                              Comment

                              Working...
                              X