No announcement yet.

Completely stumped - Rpc over HTTP

  • Filter
  • Time
  • Show
Clear All
new posts

  • Completely stumped - Rpc over HTTP

    I posted this on technet but never got one person to try an help.
    I really hope someone can help..

    First I want to use rpc over https for a couple of users. The customers all have 1 main windows 2003 server and that is it. They are all running windows 2003 Exchange Server w/Service Pack 1 applied. They all use Office 2003 with all service packs applied. I have gone through all the steps of getting rpc over http working according to all the documents that I have read. Also I created a internal standalone version of certificate server. I created a certificate with fqdn of exchange server. When I http it fails and will only let me do https which works the way it is supposed too. I also do the RPC test and it shows the correct error message as described in manyt articles. I have followed all the steps and it listens on correct ports
    6001,6002,6004...My certificate name is different than my internal name.. I used WEBMAIL.MYDOMAINNAME.COM for the certificate. My actual internal name of the Exchange Server is INTERNAL.MYDOMAINNAME.COM (THIS WORKS W/O issue for HTTPS).

    But when I try connecting my Exchange/Outlook (OUTLOOK/RPC command), i only connect using tcpip..NEVER connects with https (which would indicate that RPC is working). Everything appears to be correct..

    ALSO after creating the certificate to reflect the WEBMAIL.MYDOMAINNAME.COM name, when I go to the exchange server manager and try to access public folders I then recieve the ERROR C103B404.. which states that that my name
    does match my Exchange Servers Name (IE.. WEBMAIL does not match INTERNAL) .. I read somewhere that someone said that my internal name and external have to match for this to work.. but that is wrong. My coworker has a customer that
    he successfully can connect to VIA https (RPC). The only difference is that he actually purchased a certificate AND
    his internal name and external names are definately different.

    I put back the certificate to INTERNAL.MYDOMAINNAME.COM and the error message ERROR C103B404 goes
    away. So far I have NOT been able to get RPC over HTTPS working on any server system that I have tried to.
    Even thought My CoWorker actually got RPC over HTTPS, he has the get the same ERROR C103B404 message when he tries to access his public folders too.


  • #2
    I just set up SSL on an EX2003 server yesterday.. I had some troubles with it but figured it out..

    The internal name of the server here is but the client accesses OWA by typing and it is set to deny non-secure connections so they are always using HTTPS.

    The walk-thru that I used was right here on this site.. It's this one:

    And it does mention that "either the Name or the Common Name fields (one of them or both of them) exactly match the external FQDN of the website". This assumes that you do have the name that you are trying to use is configured in your site's DNS server(s).

    If there is anything that I could show you in my config here that would help, let me know..




    • #3
      recreate your certificate with the external fqdn of the server.

      good luck

      Good Luck


      MCSE 2003+Security;MCSE 2003+Messaging

      So, from me to all of you out there, wherever you are, remember:
      the light at the end of the tunnel may be you. Good Day!


      • #4
        if you use an Internal Cert, 1 one the 3 steps of verification will fail on the client due to your Root CA not being a trusted source (like verisign etc already are by default.)

        Try installing the Root CA certificate into your clients Trusted Root CA store.

        * Shamelessly mentioning "Don't forget to add reputation!"