No announcement yet.

Redirect installation source path

  • Filter
  • Time
  • Show
Clear All
new posts

  • Redirect installation source path

    Hello Everyone,

    I have been searching and searching and searching for a solution that I couldnt find. Not even from Microsoft.

    The problem was this:

    In the company I work for - we have about 200 - 250 users. Each user on our domain has limited user privilages. which means they cannot install applications and or updates to their office machine without ITs permission.

    Now we currently use Patch Management to deploy updates to users which works great, but, when it comes to installing the updates for our Office 2K the updates request the installation source from our server (which is a mapped path). Because the updates are being "run as" the Admin profile, the path is unreachable.

    This was the closest thing I could find from Microsoft.
    How to change the server location for Office source files

    I tried startup vbscripts which runs my batch file to change the source path, but that was pointless becuase the batch file is not running as an admin even from using a vbs.

    After about 7 hours I gave up and started to search the registry. I change 2 registry keys and walla. The solution is CRAZY STUPID EASY!!!

    Go to Start --> Run
    Type "Regedit.exe"

    1) Go to this path (Keep in mind this is for Office 2K)

    HKEY_CLASSES_ROOT\Installer\Products\904010001E872 D116BF00006799C897E\SourceList\

    change the value data for "LastUsedSource" from the "n;1;f:\office admin install point\" to the path you want "n;1;\\server\shared\office admin install point\"

    2) Now change the value data for "1" key located in the

    HKEY_CLASSES_ROOT\Installer\Products\904010001E872 D116BF00006799C897E\SourceList\Net

    from "f:\office admin install point\" to "\\server\shared\office admin install point\"

    I hope this helps

    Last edited by Yosman; 17th August 2007, 00:47.

  • #2
    Re: Redirect installation source path

    You might try assigning this through GPO, here is a link:

    I would try starting over from scratch by deploying office through GPO then performing the steps found here.

    If you come across any issues with this let me know and i will assist you.
    Technology is only as good as those who use it

    My tech blog -