No announcement yet.

Can't log into PowerShell and EAC on Exchange 2013 Server

  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't log into PowerShell and EAC on Exchange 2013 Server

    I'm not sure why but I my Exchange PowerShell can't log into my Exchange server and I can't access the EAC via localhost or the URL.

    I did notice that I enabled HTTP Proxy in IIS and that I used Application Route Requesting with it but I went ahead and reversed all those changes. I also noticed that the physical path for each sub-site in Default Web Site goes to the HTTP Proxy version of that folder instead of the ClientAccess one. I changed each folder to the clientaccess one but that didn't help. I did some research on this and I saw that I had to enable the kerbauth in the modules area and I did that to. I restarted IIS and WebRM and that still didn't help.

    The Exchange Management Shell error:

    New-PSSession : [] Connecting to remote server failed with the following
    error message : The client cannot connect to the destination specified in the request. Verify that the service on the
    destination is running and is accepting requests. Consult the logs and documentation for the WS-Management service
    running on the destination, most commonly IIS or WinRM. If the destination is the WinRM service, run the following
    command on the destination to analyze and configure the WinRM service: "winrm quickconfig". For more information, see
    the about_Remote_Troubleshooting Help topic.
    At line:1 char:1
    + New-PSSession -ConnectionURI "$connectionUri" -ConfigurationName Microsoft.Excha ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin
    + FullyQualifiedErrorId : CannotConnect,PSSessionOpenFailed
    On the web when I try to access EAC on our URL and not localhost, I get this error:

    Bad Request
    The request sent by your browser was not valid

    On localhost, I just get a page cannot be found.

  • #2
    Re: Can't log into PowerShell and EAC on Exchange 2013 Server

    So this was working prior to your changes? If so, it sounds as if you may need to look into re-creating the IIS Virtual Directories.

    On the proxy server side, do you have this enabled in the browser, so possibly it is trying to connect over the Internet>