No announcement yet.

AutoDiscovery and DNS

  • Filter
  • Time
  • Show
Clear All
new posts

  • AutoDiscovery and DNS

    i have created a bit of a problem (Yayyyy!!!)

    our autodiscover has never worked but this somehow has never been a problem(running the test for an outlook 2010 client would fail)?
    i did a little looking into it and in short found thet if i set the AutoDiscoverServiceInternalUri from https://<SERVER>.<DOMAIN>.<COM>/autodiscover/autodiscover.xml to either of the following:
    then it would work? the same goes for browsing to the locations via IE.

    this is really odd because if i ping either the <SERVER> or <SERVER>.<DOMAIN>.<COM> they both resolve to the same address just fine.

    i tried to recreate the virtual directory for autodiscover on the CAS and restart the IIS but it made no difference. i have also added a new SRV record for _autodiscover pointing to <SERVER>.<DOMAIN>.<COM> but it doesn't make a difference.

    now the fun part..... Out Of Office has stopped working >_<
    i've reverted everything back to the original settings but now, when a client clicks on the Automatic Replies in outlook, they get an error "Your automatic reply settings cannot be displayed because the server is currently unavailable. Try again later".

    i have a feeling that this is something DNS related.
    why can i connect to https://<SERVER>/autodiscover/autodiscover.xml in IE but it fails when i add <domain>.<com> after my server name?

    many thanks for any help on this

  • #2
    Re: AutoDiscovery and DNS

    You need a split DNS so that the host name resolves.
    For Autodiscover to work correctly you need the following:

    a. A host name that resolves to the Exchange server. This needs to be an FQDN.
    b. An SSL certificate on the server the clients trust.
    c. The SSL certificate must contain the host name from point a.

    Then run through the host name configuration here:

    OOTO works from the availability service, which is found with Autodiscover. So broken Autodiscover means broken OOTO and usually free/busy as well.

    Simon Butler
    Exchange MVP

    More Exchange Content:
    Exchange Resources List:
    In the UK? Hire me:

    Sembee is a registered trademark, used here with permission.