Announcement

Collapse
No announcement yet.

Problem with SSL Certificate in Outlook 2010

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with SSL Certificate in Outlook 2010

    I am running a server 2008 with exchange 2007 environment.
    Clients are running outlook 2010 and connecting to exchange locally (well, its actually a terminal server environment).

    I have just installed a new SSL certificate, and now I am getting a warning when I open outlook on the clients:


    the name on the security certificate is invalid or does not match the name of the site.


    The primary name on the security certificate is:

    mail.publicdomain.com

    It is a multi site certificate and also has these alternative names:
    autodiscover.publicdomain.com
    server.domain.local

    which are all valid.

    However, writing this I have just realised that I cannot resolve mail.publicdomain.com from the client computers, could that be the cause of the issue?

    Why would that be the case (I can resolve it from anywhere else) and should I add it into the servers DNS manually?
    David Silvester
    Systems Administrator

  • #2
    Re: Problem with SSL Certificate in Outlook 2010

    I have just added records manually for mail.publicdomain.com and autodiscover.publicdomain.com and I can ping both of them now from the clients.

    However, this certificate warning is still coming up in outlook, I don't understand why because everything seems to be correct..??

    Any ideas?
    David Silvester
    Systems Administrator

    Comment


    • #3
      Re: Problem with SSL Certificate in Outlook 2010

      You need to change the host names in Exchange to match the name on your SSL certificate.

      http://semb.ee/hostnames2007

      Simon.
      --
      Simon Butler
      Exchange MVP

      Blog: http://blog.sembee.co.uk/
      More Exchange Content: http://exchange.sembee.info/
      Exchange Resources List: http://exbpa.com/
      In the UK? Hire me: http://www.sembee.co.uk/

      Sembee is a registered trademark, used here with permission.

      Comment


      • #4
        Re: Problem with SSL Certificate in Outlook 2010

        Originally posted by Sembee View Post
        You need to change the host names in Exchange to match the name on your SSL certificate.

        http://semb.ee/hostnames2007

        Simon.
        that worked perfectly - I am not sure what was wrong as I just ran the commands to insert the correct values through shell - but I think it was something to do with the internal and external access URLs configured in exchange.

        Thanks alot!
        David Silvester
        Systems Administrator

        Comment

        Working...
        X