Announcement

Collapse
No announcement yet.

Problem Migrating Public Folders

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem Migrating Public Folders

    I have two email migrations on the go at the moment, everything has gone fine until in each case I cant seem to replicate the public folder database across to the newly created 2010 public folder database.

    Most guides I read suggest to use the inbuilt PS1 script on 2010, this does not error but also does not seem to replicate the folders -

    .\AddReplicaToPFRecursive.ps1 -server "Exch2010" -TopPublicFolder "\" -ServerToAdd "Exch2010"

    I then run the command to verify the above (I believe after running the above, there should be a listing of public folders, which I don't get)

    get-PublicFolder | FT Name, Replicas

    And all I can see from that output after 48 hours is IPM_SUBTREE

    I have tried manually selecting folders on 2003, adding the Exch2010 DB as a replica, Urgent and Always Run but nothing happens, my 2010 DB is still its original size.

    Everything is on the same subnet, I'm running it under the domain admin context.

    Can anyone advise where Im going wrong here..?

  • #2
    Re: Problem Migrating Public Folders

    If you are expecting the public folder database to shrink, then you will be disappointed. As it will not.
    To confirm if the data has replicated, there is only one command

    get-publicfolderstatistics

    If that comes back blank, then everything has gone. If it lists anything then replication is still happening.

    The references under get-publicfolder will go as soon as you run the command, that is normal, what you are waiting for is the actual data.
    Although the command you are using will only produce the result you have posted, whether you have 1 or 100 folders.

    To see a list in EMS of the public folders on the server you need to use this command:
    Get-PublicFolder -Server SERVERNAME "\" -Recurse -ResultSize:Unlimited

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: Problem Migrating Public Folders

      Many thanks for your reply.

      Upon checking the public folders on 2010 today I have found that still nothing has replicated over, the output of

      Get-PublicFolder -Server SERVERNAME "\" -Recurse -ResultSize:Unlimited

      provides me with only a single entry, IMP_SUBTREE.

      Database size is still 16MB, there are over 70GB of public folders to replicate.

      Clearly this isn't working, I believe I have gone through the correct steps to get this working but the results don't lie :/

      Comment


      • #4
        Re: Problem Migrating Public Folders

        What does Get-PublicFolderStatistics show?

        What are you replicating off? Public folder replication goes over SMTP, so any problems there can stop replication from happening.

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment

        Working...
        X