Announcement

Collapse
No announcement yet.

Exchange server 2010 some mails to two domains stuck in mail Queue with 451 4.4.0

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange server 2010 some mails to two domains stuck in mail Queue with 451 4.4.0

    Based server is windows server 2008 R2 and installed MS exchange 2010 .
    Currently mails sent to 2 domains stuck in mail queue , with two different errors in smtp logs

    First one is 450 4.1.8 <[email protected]>: Sender address rejected: Domain not found ...all of 10 mails sent to this domain stuck there.

    Next one is to another domain with different error.

    451 4.4.0 Primary target IP address responded with :"421 4.4.2 Connection dropped due to SocketError.

    can do nslookup to the domain
    and when I test telnet to port 25 result shows
    220 mx.theirservername ESMTP
    EHLO mydomain.com
    250-theirmailserver.com
    250-PIPELINING
    250-SIZE 209000000
    250-ETRN
    250-STARTTLS
    250-ENHANCEDSTATUSCODES
    250 8BITMIME
    its seems going through right? Need advice !!!
    The other mails to other domains can successfully sent through ..

  • #2
    Re: Exchange server 2010 some mails to two domains stuck in mail Queue with 451 4.4.0

    The first one is not your problem. The remote server is rejecting the email.
    Most likely the MX records are setup incorrectly or there is a cluster of servers and one of them is wrong. Not a huge amount you can do because it is out of your control. Inform the recipient that there is a problem.

    You could route email for that domain through a smart host. Check if your ISP has an SMTP server you can use.

    The second one is a connection failure. Can often be caused by something scanning the SMTP traffic or a firewall.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: Exchange server 2010 some mails to two domains stuck in mail Queue with 451 4.4.0

      Thank you sembee ,

      The first domain has 4 mx servers and may be one of them got error.

      For the second one I tried to create a new send connector and restart my transport service and seems all mails go through but I have to monitor.

      for the first one still got error ...
      I already talked to their IT but seems no help yet ..

      Comment

      Working...
      X