Announcement

Collapse
No announcement yet.

Very strange issue with outlook in Exchange 2010 environment

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Very strange issue with outlook in Exchange 2010 environment

    I have a new system running SBS 2011, brand new install (migrated from SBS 2003, but done manually (Set up new server from scratch, add user accounts manually, import data and email (PSTs).

    Anyway, Excuse me if this is in the wrong section, but the issue is really relating to Outlook and Exchange 2010 - so I thought this would be the best place.

    Anyway, the issue concerns two users - User A and User B.

    They both run Windows 7 Pro and Outlook 2010.

    User A has access to the mailbox of User B.

    If User A places an email item from their mailbox into a folder within User B mailbox, it appears in there for a minute or so, then disappears.
    Once it disappears, it cannot be found anywhere - neither in User A or User B mailbox, or in deleted items recovery.

    I have managed to replicate the issue several times with the above procedure.

    Not sure where to go from here!
    David Silvester
    Systems Administrator

  • #2
    Re: Very strange issue with outlook in Exchange 2010 environment

    Shouldn't happen, are both mailboxes in cached mode or non-cached mode?

    Is the User B mailbox added as an additional mailbox or as a distinct account in the profile?

    Comment


    • #3
      Re: Very strange issue with outlook in Exchange 2010 environment

      User B mailbox is added as an additional mailbox - I just add permission for User A to access user B in exchange 2010 ESM and it automatically adds it to User As outlook.

      They are both in Cached Exchange mode. There was a reason for that, but I cant remember what it was.

      Perhaps I should try turning of cache?
      David Silvester
      Systems Administrator

      Comment


      • #4
        Re: Very strange issue with outlook in Exchange 2010 environment

        Yes it might give you a better idea. Also you can try adding the mailbox explicitly:

        File - Account Settings - New

        Does it happen irrespective of User B's Outlook being opened at the same time or not?

        Comment


        • #5
          Re: Very strange issue with outlook in Exchange 2010 environment

          Thanks, thats given me a few ideas to try and pin down the issue.
          Ill try those and report back.
          David Silvester
          Systems Administrator

          Comment


          • #6
            Re: Very strange issue with outlook in Exchange 2010 environment

            I tested the same scenario without User B having outlook open, and it still done the same thing.

            I was going to remove the account (from additional mailbox) and then add it back as an account in its own right (Am I right in thinking since outlook 2010 you can have multiple exchange accounts on teh same profile?), But it wont let me delete it - when I try to delete the additional mailbox, it says "this set of folders is part of an existing account, please goto file>info>accounts, select the account and select remote.

            However, in account settings, there is only the main account (For User A) and in that account, under settings, there is nothing in additional mailboxes.

            I will try configuring a new profile and see if it occurs.
            David Silvester
            Systems Administrator

            Comment


            • #7
              Re: Very strange issue with outlook in Exchange 2010 environment

              UPDATE:
              I just created a new profile for User A and set it up exactly the same - just added User A, but then I turned off cached exchange mode.

              Once I went into outlook, again User B was automatically added (A new feature of exchange 2010 I believe), but this time the issue does not occur - ie I can successfully move items from User A to User B and they don't disappear.

              So I guess it was cached mode causing an issue, but why, cant be normal behaviour?
              David Silvester
              Systems Administrator

              Comment


              • #8
                Re: Very strange issue with outlook in Exchange 2010 environment

                Could be a corrupt Outlook profile. Cached mode shouldn't cause this issue.
                Regards,
                Jeremy

                Network Consultant/Engineer
                Baltimore - Washington area and beyond
                www.gma-cpa.com

                Comment


                • #9
                  Re: Very strange issue with outlook in Exchange 2010 environment

                  Originally posted by JeremyW View Post
                  Could be a corrupt Outlook profile. Cached mode shouldn't cause this issue.
                  Hmm, very strange.
                  If time permits, I will re-create everything and see if it still does it.
                  Thanks for the help.
                  David Silvester
                  Systems Administrator

                  Comment

                  Working...
                  X