Announcement

Collapse
No announcement yet.

Exchange 2010 No Incoming Internet Mail

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange 2010 No Incoming Internet Mail

    Today I tried to add a 2nd email address to my exchange server but accidentally checked the "Automatically update email address based on email policy" setting.

    Ever since then I have not been able to get incoming mail. I tried to change the policy settings, turn it off and back on again, reboot the server, the client, Restart transport and information stores etc etc ...Nothing. The policy was not configured or applied previously and all worked fine. But I cannot get it to work with any settings or turn it back off. I can get it to show "false" in the applied column but still no incoming mail.

    Internal mail works between accounts Outgoing mail works from both accounts but no incoming from the internet.

    I have an internal domain and an external domain which name is different. Both names are in the Accepted Domains List. I've put both names in the default policy and changed the "local part" setting to just about everything and nothing works.

    When I try to configure mail at the client by doing a repair on the profile it says "problem accessing server"

    I'm sure this is a simple thing but I can't seem to figure it out. Any ideas?
    Last edited by Merlin_78704; 22nd November 2013, 20:24. Reason: More detail

  • #2
    Re: Exchange 2010 No Incoming Internet Mail

    Been working on this all day and probably made things worse if anything. All I can tell is my autodiscover is all hosed up.

    I use network solutions for Email but my MX record on my server is set to the internal exchange server. Not sure that's right but it was working before.

    The Network solutions MX record shows its own server for the domain.
    If I do an nslookup from my network I get my exchange server but if I do it from an external source I get Netsol's server.

    I cant imagine this is from anything related to the default policy since I've changed most of the settings several times with no difference in result.

    I read somewhere that this messes up your MX record somehow not sure which MX record is the correct one. But Network Solutions shows theirs and the internet shows theirs but internally my Exchange server is the MX.

    This problem initially started when I created a 2nd email account within network solutions and then went on my exchange server and created it there. As I said in the original post. I accidentally clicked ok before unticking the "Default policy" Checkbox and incoming internet mail stopped.

    The default policy was not defined or applied previously, but I don't understand how that could hose things up like it did.

    Anyone have any ideas on where to go next? I think i'm probably just making things worse if I continue on.

    Comment


    • #3
      Re: Exchange 2010 No Incoming Internet Mail

      I recently had a client that did this... the problem is twofold: 1. you created an email account in Network Solutions and 2. Network Solutions was being "helpful" by automatically changing the MX records to their servers since you setup an email account there.

      You need to setup an A record (or find out what the A record is) for you public IP address. Then change your MX record to point to that A record for your public IP address.

      The internal MX records have no bearing.
      Regards,
      Jeremy

      Network Consultant/Engineer
      Baltimore - Washington area and beyond
      www.gma-cpa.com

      Comment


      • #4
        Re: Exchange 2010 No Incoming Internet Mail

        Thank You so much Jeremy!!!you were correct that was exactly what happened. Flipped my MX record and it started working again.

        Comment


        • #5
          Re: Exchange 2010 No Incoming Internet Mail

          Well incoming mail seems to be working now but autodiscover still isn't working correctly.

          I use a self signed certificate so I know that it breaks some things but I think autodiscover is unaffected by this. I had an autodiscover record in my external DNS which I deleted. I didn't think I needed it. Could that be why it's not working now?

          Comment


          • #6
            Re: Exchange 2010 No Incoming Internet Mail

            Where is your autodiscover not working? Internally or externally?
            Regards,
            Jeremy

            Network Consultant/Engineer
            Baltimore - Washington area and beyond
            www.gma-cpa.com

            Comment


            • #7
              Re: Exchange 2010 No Incoming Internet Mail

              I use a self signed certificate so a lot of those functions don't work externally. Would be nice to get mail on my iphone, but anyway to answer your question it is internal that isn't working. I have to manually type in the server name and the email account checks out fine and the mail is working but the dialog always comes up with "problem connecting to server". By dialog I mean when you go into control panel mail and try to change or repair a profile account.

              Comment


              • #8
                Re: Exchange 2010 No Incoming Internet Mail

                I wonder do I need an internal autodscover dns record?

                Comment

                Working...
                X