No announcement yet.

First Exchange 2013 install in Child domain

  • Filter
  • Time
  • Show
Clear All
new posts

  • First Exchange 2013 install in Child domain


    I have a question about preparing AD for exchange 2013. I have a new Domain controller running at the root of my domain

    I have created a new child domain (domain controller) and also added a seperate Member server for exchange 2013. All Servers are running 2012 Standard Edition. Currently there is no exchange anywhere in the forest.

    My question is this. In order to introduce my first exchange server installation (on the member server in the child domain) where should I be running the ADPrep commands.

    Should I run Setup /IAcceptExchangeServerLicenseTerms /PrepareSchema at the forest root level domain controller first or do I run this in my Child Domain DC

    ALso am I correct in saying that I should run Setup /IAcceptExchangeServerLicenseTerms /PrepareAD /OrganizationName:yourOrganizationalname on all my domain controllers in this scenario

    I am happy with all the required prerequisites it is just the schema preparation and where it should be run that I am struggling with.

  • #2
    Re: First Exchange 2013 install in Child domain

    The schema will be needed to be prepared in the root Domain to start with.


    • #3
      Re: First Exchange 2013 install in Child domain

      Following on from this I have ran the schema update on the forest root server
      I have also then ran the AD prep command again on the forest root server. Both ran successfully.

      I then drop to my Child domain controller to run the Domain Prep and I get an error stating

      The Active Directory schema isn't up-to-date, and this user account isn't a member of the 'Schema Admins' and/or 'Enterprise Admins' groups. For more information, visit:

      My forest root server is a windows 2012 DC
      My Child DC is again WIndows server 2012 Added as a Child to an existing forest
      I have a member server windows 2012 that I will be installing my first exchange 2013 instance into. No other exchange exists in this environment.

      I have verified Replication has no errors and also manually added my child domain admin account to the root domain enterprise admin and schema admin groups.

      Should I be running the domain prep command also at the root DC rather than my child DC?

      Or should I be looking to try and run Schema / Ad and Domain Prep all at the child DC as well?


      • #4
        Re: First Exchange 2013 install in Child domain

        It could mean the replication hasn't finished yet, but Google/Bing for this article for a explanation with steps and permissions required: Prepare Active Directory and Domains (sorry, can't post URLs yet :-S)
        It also provides information on how tho check whether these steps have completed successfully.