Announcement

Collapse
No announcement yet.

outlook 2010 connect error with exchange 2013

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • outlook 2010 connect error with exchange 2013

    I have just installed 3 new Windows 2012 servers, 2 as Domain Controllers and 1 with Exchange 2013.
    When I try to setup Outlook 2010 with a user I get , firstly, a certificate error.
    http://peecee.dk/upload/view/414857
    When I press Ja (Yes) I get the following error:
    "There is no connection to Microsoft Exchange. Outlook must be online or have a connection to perform the action."
    I get the same error when I try to setup Outlook manually.

    What to do?

  • #2
    Re: outlook 2010 connect error with exchange 2013

    I'm pretty sure that's a self-signed certificate error. (I hsould know which one sits where on the dialog, but I don't.)

    You will need to import the trusted root certificate authority, or get a proper certificate from somewhere like certificates4exchange.com
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

    Comment


    • #3
      Re: outlook 2010 connect error with exchange 2013

      That explains the certificate error, but what about the problem with outlook not being able to connect to the exchange server?

      Comment


      • #4
        Re: outlook 2010 connect error with exchange 2013

        it's trying to use Outlook Anywhere, which requires a trusted certificate.

        Add the trusted root CA to your local root CA store and it should work.
        (or - get a real certificate)
        Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

        Comment


        • #5
          Re: outlook 2010 connect error with exchange 2013

          MAPI/RPC access via the Outlook Client has been removed in Exchange 2013. It's now RPC over HTTPS using Outlook Anywhere, hence, the SSL certificate issue causing the Outlook connection problem.

          For example, the RPC CAS array object has now disappeared as well.

          Comment


          • #6
            Re: outlook 2010 connect error with exchange 2013

            I have installed a valid certificate, but I still certificate error when I try out connect outlook, but when I press Yes outlook connects. The certificate error is for the internal FQDN exchange server and when looks at the settings the server outlook is connected to is a lot letters @[my domain]. Why is that?

            Comment


            • #7
              Re: outlook 2010 connect error with exchange 2013

              The reason you are getting errors about your local domain is probably because you have missed one of the URLs in Echange and it is still using the internal domain rather than the external.

              You need to ensure that the external name resolves internally to the internal IP address via split DNS, then change Exchange to use those URLs instead.

              My article for Exchange 2010 applies to Exchange 2013 as well:
              http://semb.ee/hostnames

              On the subject of the server name in Outlook - each user gets a unique end point as their Exchange server name. That is normal and should be ignored.

              Simon.
              --
              Simon Butler
              Exchange MVP

              Blog: http://blog.sembee.co.uk/
              More Exchange Content: http://exchange.sembee.info/
              Exchange Resources List: http://exbpa.com/
              In the UK? Hire me: http://www.sembee.co.uk/

              Sembee is a registered trademark, used here with permission.

              Comment


              • #8
                Re: outlook 2010 connect error with exchange 2013

                After making the changes you recommended I still get certificate error for the server with the local FQDN.

                Comment


                • #9
                  Re: outlook 2010 connect error with exchange 2013

                  You must have missed one.

                  Do an Autodiscover test, look at the results and see which one is still on the internal name.
                  http://semb.ee/adt

                  Simon.
                  --
                  Simon Butler
                  Exchange MVP

                  Blog: http://blog.sembee.co.uk/
                  More Exchange Content: http://exchange.sembee.info/
                  Exchange Resources List: http://exbpa.com/
                  In the UK? Hire me: http://www.sembee.co.uk/

                  Sembee is a registered trademark, used here with permission.

                  Comment


                  • #10
                    Re: outlook 2010 connect error with exchange 2013

                    So you have renamed EWS and Autodiscover and Internal/External URLs for other Exchange servcies such as OWA match the SSL certificate SAN?

                    Comment


                    • #11
                      Re: outlook 2010 connect error with exchange 2013

                      All internal address have been change to external address but I still get certificate error with a internal name for my exchange server.

                      Comment


                      • #12
                        Re: outlook 2010 connect error with exchange 2013

                        So effectively, have you carried out the below as well?


                        (1) Verified EWS URLs

                        Get-WebServicesVirtualDirectory |fl identity,internalurl,externalurl

                        Set-WebServicesVirtualDirectory -Identity “NetbiosNameofCASServer\EWS (Default Web Site)” -InternalUrl
                        https://External URL/EWS/Exchange.asmx -BasicAuthentication:$true


                        Set-WebServicesVirtualDirectory -Identity “NetbiosNameofCASServer\EWS (Default Web Site)” -ExternalUrl https://External URL/EWS/Exchange.asmx -BasicAuthentication:$true

                        (repeated the above for each CAS server name)


                        (2) Verified the Autodiscover Service URI

                        Get-AutodiscoverVirtualDirectory

                        Get-ClientAccessServer |fl identity,autodiscoverserviceinternaluri

                        Set-ClientAccessServer -Identity NETBIOSNameofCAS -AutoDiscoverServiceInternalUri
                        https://ExternalURL/Autodiscover/Autodiscover.xml

                        (repeated the above for each CAS server name)


                        (3) IIS reset after the above

                        Comment


                        • #13
                          Re: outlook 2010 connect error with exchange 2013

                          After running the commands you listed I still get certificate error.

                          The cert. error comes right after I have opened Outlook 2013 on my network. I have all so notished at my connection with Outlook 2013 on my domain is through HTTPS and not TCP/IP.

                          Comment


                          • #14
                            Re: outlook 2010 connect error with exchange 2013

                            That is the correct behaviour. On Exchange 2013 the only connection method is HTTPS - nothing else. There is no TCP/IP connection any longer.

                            If you are still getting prompts then either you have missed a setting or your DNS isn't correct.

                            Simon.
                            --
                            Simon Butler
                            Exchange MVP

                            Blog: http://blog.sembee.co.uk/
                            More Exchange Content: http://exchange.sembee.info/
                            Exchange Resources List: http://exbpa.com/
                            In the UK? Hire me: http://www.sembee.co.uk/

                            Sembee is a registered trademark, used here with permission.

                            Comment


                            • #15
                              Re: outlook 2010 connect error with exchange 2013

                              Okay lets look at the DNS.

                              My domain internal is .local and eksternal is .dk. In my DNS server I have made a zone called [domain].dk and in that zone I have made a CNAME called mail that points to exchange server in [domain].local zone.

                              Comment

                              Working...
                              X