No announcement yet.

Co Existing Exchange 2010 and Exchange 2003 and Cannot send email Externally

  • Filter
  • Time
  • Show
Clear All
new posts

  • Co Existing Exchange 2010 and Exchange 2003 and Cannot send email Externally

    Please Help,

    Friday night I added an Exchange 2010 SP1 Server to my Exchange 2003 Domain. We can successfully send and receive Exchange mail internally between Exchange 2003 and Exchange 2010 mailboxes. We can also receive External email but we cannot send external email. Also SMTP relay messages relay to Exchange 2010 mailboxes but not Exchange 2003 mailboxes.

    Here are Domain Details:

    Exchange 2003 and Exchnage 2010 Server has an internal network card connected to our network and an External card connected to the internet through a firewall.

    We use message labs to route our email externally.

    On our Exchange 2003 server we had a Routing Group called SMTP Connector 1. This was set to forward email to messagelabs as a smart host and we had a local bridgehead to a virtual server “Default SMTP virtual”. My Default SMTP Virtual Server. The local bridgehead has relay restrictions with allow internal IP’s allow to send”

    After I installed Exchange 2010:

    On New Exchange 2010 Server
    • Added “Anonymous users” to my “Default Server Connector”
    • Added a Receive Connector called Relay Restrictions. That is set to, I have the local exchange server IP as IP address to receive, Added IP’s to receive from, Authentication is TLS and Externally Secured, and Permissions groups are Anonymous Users and Exchange Servers.
    • Added an Internet Send Connector with, Address Space SMTP * and cost 1, Network Use MX Records, and my Exchange 2010 Server as source Server.

    On Exchange 2003 Server:
    • Removed Smart Host on SMTP Connector 1 and chose to use DNS records
    Then I thought maybe I need to Change my new “Internet Send Connector” to use my smart host. So I added that and it still doesn’t work. I also am restarting the Transport server every time I make a change to an connector.

    I have 2 Domains in DNS, one External and one Internal. I added to 2 CNAME’s in my external Domain one for pointing to exchange 2010 server and one for pointing to exchange 2003. Also created 2 (A) records one to mail to Ip of Exchange 2010 and one to legacy to IP of Exchange 2003 server.

    I see in the Queue all the messages with an error 451 4.1.0 DNS Query failed.

    Thanks to anyone that can help me resolve this ASAP.

  • #2
    Re: Co Existing Exchange 2010 and Exchange 2003 and Cannot send email Externally

    One Correcting

    My 2 default receive Connectors use exchange2010server.internaldomain.msft and my relay connector i created uses

    My Default SMTP connector 1 does not use a FQND but my Internet Send connector uses

    Is this right?


    • #3
      Re: Co Existing Exchange 2010 and Exchange 2003 and Cannot send email Externally

      OK, I removed TLS from the default Server Connector and restarted the transport service and nothing was fixed. Checked “Register this connection addresses in DNS” (i had unchecked this yesterday) on the internal team on the Exchange 2003 server. Rebooted the Exchange 2003 server and when the server came back up, all the email sent out.

      Tested all mail-flow and email was sent out externally and I was able to send back and forth with Exchange 2010 and Exchange 2003. This was at 4:30pm.

      Just tested again at 11:30pm and I am able to send externally from exchange 2010 and exchange 2003. I am able to receive emails back from externally on my exchange 2010 mailbox but not my exchange 2003 mailbox.

      Once again I see the queue filling up on Exchange 2010 with the error 451 4.1.0 DNS Query failed.

      Reboot, 15 min later everything is working again.

      Oh my goodness. I don't know what to do here. What could possibly be causing it to stop working after 7 hours?


      • #4
        Re: Co Existing Exchange 2010 and Exchange 2003 and Cannot send email Externally

        Exchange 2010 SP1 is very old - I guess you made the common mistake of downloading the media from the Volume Licencing site?
        Exchange service packs are the complete product, so you can install a new installation straight from the service pack. Therefore the first thing I would suggest that you do is install Exchange 2010 SP3 on to the server.

        If you need to route email via Message Labs then that should be done via an SMTP Connector on Exchange 2003 and a Send Connector on Exchange 2010. Do ensure that the routing group connectors are in place between the two platforms.
        You can delete the SMTP Connector on Exchange 2003, as long as the Exchange 2010 Send Connector is configured correctly then Exchange 2003 will use that as well, routing email out via Exchange 2010.

        Simon Butler
        Exchange MVP

        More Exchange Content:
        Exchange Resources List:
        In the UK? Hire me:

        Sembee is a registered trademark, used here with permission.


        • #5
          Re: Co Existing Exchange 2010 and Exchange 2003 and Cannot send email Externally

          I want to get away from using the Exchange 2003 server so that I can remove it from our domain.

          I have my internet send connector set to point traffic to MX records and they are forwarding to Message Labs (with a send connector) so no need to fix this.

          So I think I'm on to something. Earlier today I got an event log from one of our IP's (Servers) that we need to relay to email that said my recieve connector "Relay" rejected an incoming connection from IP address The maximum number of connections per source (20) for this connector has been reached by this source IP Address. So I had something to go by.

          I ran, Set-ReceiveConnector -Identity "Relay" -Banner "220 SMTP OK" -ConnectionTimeout 00:5:00. This instantly released all messages.

          So then I set the maximum to 10000 so that we wouldn't have this problem again.

          4 hours later the SmtpRelayToTiRg queue starts filling up again with 451 4.1.0 DNS Query failed. I tried restarting the server as this helped in the past, however it didn't work. I didn't get the event log like I did last time for the IP, but I thought I would give the Set-ReceiveConnector -Identity "Relay" -Banner "220 SMTP OK" -ConnectionTimeout 00:5:00 a try again and....

          Bam, instantly emails all came in at once. Do you have any ideas what the hold up is?