Announcement

Collapse
No announcement yet.

Virtual directory for autodisover not being created in IIS 7 using Exhchange 2007 SP3

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Virtual directory for autodisover not being created in IIS 7 using Exhchange 2007 SP3

    Hello, I did do a search on this, but I didn't quite get the answer I was looking for.

    System: Windows 2K8 (not R2)
    Exchange 2007 SP3
    IIS 7

    When I first installed Exchange all the web sites under IIS were created successfully such as OWA, OAB, etc. I ran the power shell commands to set up autodiscover including the client access command to point to the autodiscover xml file.

    However, when I checked out IIS, the only thing that was created was the bin and help directory for autodiscover. Am I missing something here? Shouldn't there be a virtual directory called autodiscover? If so, I would appreciate some advise on how to configure this properly. Its kind of funny cause Outlook 2007 does pick up the autodiscover but it keeps telling me that outlook is "offline." I set up connection over HTTP proxy but still having the same issue.

    My DNS host name "autodiscover" is bound to the correct IP address etc. No issues with that, but I just don't understand why exchange didn't add the virtual directory in IIS 7

    I tested my autodiscover settings at Microsoft's testexchange website. DNS good and resolving the name is all good for both mail.domain.com & autodiscover.domain.com. I also get the HTTP redirect error saying there was no redirect set up for autodiscover.

    Thanks for you time for looking into this! I hope I didn't make this question too difficult and if you need more info, I will be glad to share it.

  • #2
    Re: Virtual directory for autodisover not being created in IIS 7 using Exhchange 2007

    Does autodiscover work internally for Outlook? What are you trying to configure? Are you using a 3rd party SSL certificate?

    Comment


    • #3
      Re: Virtual directory for autodisover not being created in IIS 7 using Exhchange 2007

      I don't have any machines joined to to the domain. I'm setting this is up for external use only. I know if I joined a client machine to the domain autodiscover will work fine.

      When I browse to autodiscover.domain.com/autodiscover/autodiscover.xml locally I get the "600" error message which is good. I browse to it externally and it prompts me for my credentials, I log in with no authentication issues. I can ping the host and it resolves to an IP address so that's good too.

      I don't know why I asked about autodiscover not creating a virtual directory in IIS 7. By default during the exchange install it installs it and nothing more needs to be done in IIS 7.

      I don't have any 3rd party SSL certs as of yet but am planning on it.

      Outlook picks up autodiscover just fine externally, but after that it won't prompt me for a user name and password and tells me that Outlook must be online, etc.

      When I run the test at testexchangeconnectivity.com it immediately tells me that autodiscover can not be reached/detected? How is that when I can ping it, the DNS is good, the test actually can resolve it to an IP on port 443, etc. Also, it can't find autodiscover by HTTP redirect. There has got to be something I'm missing/overlooking and somewhere the configuration isn't right.

      Any suggestions?

      Thanks for your time.

      Comment


      • #4
        Re: Virtual directory for autodisover not being created in IIS 7 using Exhchange 2007

        Personally, I would ensure the SSL certificate is configured first of all especially if you plan on doing so. Do you use a reverse proxy at all? How have you setup autodiscover externally in DNS? SRV record, Host name of autodiscover? Can you verify whether your internal Domain name is the same as External.

        Also, worth looking at your web services and autodiscover settings.

        Get-WebServicesVirtualDirectory |fl identity,internalurl,externalurl

        Get-AutodiscoverVirtualDirectory

        Get-ClientAccessServer |fl identity,autodiscoverserviceinternaluri

        Again, get your SSL certificate properly configured.

        Comment

        Working...
        X