Announcement

Collapse
No announcement yet.

Exch 2003 to 2010 Migration issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exch 2003 to 2010 Migration issue

    I am on the final steps of migrating my 2003 exchange server to 2010 but have ran into an issue when I moved a test mailbox over to the 2010 box. ( I have installed UCC SLL cert from godaddy)

    When I connect to the new exchange with outlook 2010 to test the moved mailbox I get the following errors:
    Click image for larger version

Name:	exch2010error.png
Views:	1
Size:	24.6 KB
ID:	469596 Click image for larger version

Name:	exch2010error2.png
Views:	1
Size:	27.4 KB
ID:	469597

    Most of the online answers suggest to apply the following changes from the EMC:

    Set-ClientAccessServer -Identity CAS1 -AutodiscoverServiceInternalUri https://webmail.mycompany.com/autodi...todiscover.xml

    Set-WebServicesVirtualDirectory -Identity “CAS1\EWS (Default Web Site)” -InternalUrl https://webmail.mycompany.com/ews/exchange.asmx

    Set-OABVirtualDirectory -Identity “CAS1\oab (Default Web Site)” -InternalUrl https://webmail.mycompany.com/oab

    I have applied the changes above and even tried different variations like https://mylocalexch2010name/ews/exchange.asmx with no luck.

    I can click yes on the alerts and mail flows fine but I do not want to move the mailboxes over until I get this issue resolved.

    Do I need to make changes to A records with my registrar or on my local DNS?

    I also have NOT changed port 443 forwarding on my firewall to point to new server because I have iphones and outlook anywhere users. Would this cause the issue??

    Thanks in advance for any help and advice!

  • #2
    Re: Exch 2003 to 2010 Migration issue

    The URLs for autodiscover, EWS, OAB and so on depends on the SANs you have registered with your godaddy certificate.

    The error clearly states that something is wrong in this direction, without knowing which SANs you have used it's difficult to say.

    Comment


    • #3
      Re: Exch 2003 to 2010 Migration issue

      Use the Exchange 2010 GUI to review the SSL certificate. Also, determine the URL being used by autodiscover. You can do that via the Outlook Client itself and using options available on the Outlook icon within the notification area.
      Last edited by Virtual; 7th June 2012, 09:27. Reason: addedthe word do

      Comment


      • #4
        Re: Exch 2003 to 2010 Migration issue

        I added the SAN "CAS.localdomain.local" and "autodiscover.domain.com" to my UCC cert on godaddy, re-keyed, and installed.

        I am now only getting the one error related to autodiscover.domain.com

        Virtual Re: Exch 2003 to 2010 Migration issue
        Use the Exchange 2010 GUI to review the SSL certificate. Also, determine the URL being used by autodiscover. You can that via the Outlook Client itself and using options available on the Outlook icon within the notification area.
        I think you were talking about this and here are my results.
        Click image for larger version

Name:	excherror3.png
Views:	1
Size:	41.4 KB
ID:	466531

        Does the image above shed any light on what SAN I need to add to my cert?

        What A record do I need to add to my registrar?

        Comment


        • #5
          Re: Exch 2003 to 2010 Migration issue

          It is first attempting to use an address beginning with email.????.com. Is that the address configured for the Exchange web services? If so, you can add that to the certificate and should do.

          Comment


          • #6
            Re: Exch 2003 to 2010 Migration issue

            I had an A record with my registrar that was autodiscover.mydomain.com. I removed this A record, waited a while and I am not getting the error anymore on my test mailboxes! Thanks for the replied.

            Comment

            Working...
            X