No announcement yet.

Exchange 2010 Unable to Relay

  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange 2010 Unable to Relay


    I'm new to this forum as a member but I have used it for answers in the past, so thanks to all.

    My issue is with a Postfix server using an Exchange 2010 server to relay mail. I have added a Receive Connector under EMC > Server Configuration/Hub Transport with the following settings as advised in several on-line HOWTOs:
    Network Local IP Address(es) I added a secondary address to the server for this connector and specified it here with port 25
    Receive from... IP Address set to the Postfix server
    Authentication: TLS and Externally Secured selected
    Permission Groups: Exchange Servers (also tried Anonymous users and both)
    I ran the Exchange Shell command [PS] C:\Windows\system32>Get-ReceiveConnector "Postfix Relay" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "Ms-Exch-SMTP-Accept-Any-Recipient" fo rthe Anonymous user setting as instructed

    When sending mail via the Postfix server it spits out the following:

    550 5.7.1 Unable to relay (in reply to RCPT TO command))

    Where to now?

  • #2
    Re: Exchange 2010 Unable to Relay

    Permission Groups have to include Anonymous Users.

    As long as "Externally Secured" is selected there is no need to run the Powershell command to grant those right because it will be included.

    I would set the FQDN of this receive connector to something else than the default one, this way you see at what connector your are connecting.

    Test the settings first using a telnet tool.