Announcement

Collapse
No announcement yet.

Cannot send or receive email either internally or externally

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot send or receive email either internally or externally

    I am a relative novice with Exchange 2007 and my setup is not working at all. I have been unable to figure out why. Any help would be greatly appreciated. Here are some details.

    Windows Server Standard FE SP2 ( SBS 2008 )
    Exchange 2007 SP1

    Emails sent to internal users (even to my own account from my account) go nowhere. There is no record of the message or bounceback. It shows up in the sent items folder of Outlook but it dies there.

    Emails sent to external addresses go nowhere.

    Emails sent from external addresses will eventually get an error message. It took more than 24 hours to get an undeliverable message last time I tried.

    My site (we will call it hello) is located at w w w. hello. c o m (sorry for the spaces but I cannot post URLs, even fake ones)
    I can access the server remotely by visiting remote. hello. c o m
    My domain is hosted by GoDaddy and the mx record is set to remote. domain. c o m. and the a record is set to the correct ip address.
    My internal domain is hello. local

    I have tried searching for answers online (obviously) and tried a number of things recommended for various issues. I don't even know what the original setup looked like at this point. I am at a loss and do not know where to go from here. Any help is greatly appreciated. Please let me know what other information would be helpful.

    Thanks.
    Last edited by Sembee; 4th November 2011, 00:42. Reason: Corrected to remove emoticon bug

  • #2
    Re: Cannot send or receive email either internally or externally

    Since it is SBS 2008, the best advice is UTFW (Use The Friendly Wizard) -- specifically the "configure internet and email" one.

    That should set up all the correct queues and policies for internal and external message delivery.

    If that still doesnt fix things, please post back, particularly any error messages the wizard generates.
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: Cannot send or receive email either internally or externally

      Now I am getting port errors. I am working on opening a port other than 25 for SMTP as it is blocked by my ISP.

      Comment


      • #4
        Re: Cannot send or receive email either internally or externally

        Somehow my crystal ball missed that bit in the original post. I presume the wizard gave internal flow before you changed things?
        Your chance of doing that in SBS is slim to non-existant -- it expects to use 25 and gets very upset otherwise.

        Can you upgrade your connection to allow 25?

        Could you also tell us exactly what you have changed from the OOB installation and there may be some help we can give.
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd
        Scotland

        ** Remember to give credit where credit is due and leave reputation points where appropriate **

        Comment


        • #5
          Re: Cannot send or receive email either internally or externally

          Thanks for your help. I am dealing with Comcast to see what I can do about opening port 25.

          As for the changes from the defaults, I do not remember all of the changes. Probably not a smart idea on my part not to keep a list.

          I will post what info I can after dealing with Comcast - so it might be a year or two until my next post.

          Comment


          • #6
            Re: Cannot send or receive email either internally or externally

            Apparantly, I have bigger issues than I realized. I contacted Comcast (my ISP) and they assure me that they are not blocking any ports on my account.

            I realized that I can remote login to the server but I cannot ping it. I can telnet into some ports, but not others. I am working with my domain hosting company to try to resolve it. I will post back when I know more.

            Comment


            • #7
              Re: Cannot send or receive email either internally or externally

              Good luck!
              Tom Jones
              MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
              PhD, MSc, FIAP, MIITT
              IT Trainer / Consultant
              Ossian Ltd
              Scotland

              ** Remember to give credit where credit is due and leave reputation points where appropriate **

              Comment


              • #8
                Re: Cannot send or receive email either internally or externally

                I would start by installing Exchange 2007 SP3 on to the machine. SP3 is SBS aware so doesn't require anything special to update it. SP1 is no longer supported. That may well clear a number of issues up as it effectively reinstalls Exchange.

                Simon.
                --
                Simon Butler
                Exchange MVP

                Blog: http://blog.sembee.co.uk/
                More Exchange Content: http://exchange.sembee.info/
                Exchange Resources List: http://exbpa.com/
                In the UK? Hire me: http://www.sembee.co.uk/

                Sembee is a registered trademark, used here with permission.

                Comment


                • #9
                  Re: Cannot send or receive email either internally or externally

                  Well...I made some progress. There was an error in the mx records, although it was working before. I fixed those errors and now I can send/receive internal email and receive external emails with no problem. A little slow, but I will work on that.

                  Now I need to figure out why I cannot send external emails. I have checked the send connectors and everything looks correct. I am going to install SP3 and see what happens from there. I will post back when I know more. Thanks for your help so far.

                  Comment


                  • #10
                    Re: Cannot send or receive email either internally or externally

                    Have you followed http://www.amazon.co.uk/Windows-Smal...4228115&sr=8-8?

                    SBS does most things by default once you've setup your MX records, etc.!

                    Comment

                    Working...
                    X