Announcement

Collapse
No announcement yet.

Forms authentication fails - login screen just refreshes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Forms authentication fails - login screen just refreshes

    All:

    Been driving me crazy. Exchange 2007 OWA will not allow users to login. If I use Windows NT auth it works fine. But Forms Based Authentication fails. There is no error, the login screen just redraws itelf. I have removed and rebuilt the OWA directories.

    I see a 401 error in the iis logs after it attempts owaauth.dll . But other than that I have nowhere else to turn. Default website is anonymous, OWA is basic.

    I am at my WITS END! I need real solid help here asI feel rather Googled out. Turn me over.

  • #2
    Re: Forms authentication fails - login screen just refreshes

    Are you fully SP'd / patched
    Quite possibly a reinstall of the CAS role would fix broken/missing files in IIS
    (I note you have already rebuilt OWA but may be still worth going further)
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: Forms authentication fails - login screen just refreshes

      Thank you. Well I am SP'd to SP3. Funny thing is last week this was working (to a point). I could log in, another admin could log in but my test user (non admin) could not. Made the user a member of domain admins but he could not log in. Also, had a user with an Outlook problem and he is not domain admin but he could get in.

      But now it's all moot as nobody can log in. Don't know what happened. Maybe our Windows Update server patched and rebooted over the weekend? We are also fairly locked down with policy but I would have seen that right away.

      Sigh.

      Comment


      • #4
        Re: Forms authentication fails - login screen just refreshes

        Reset the virtual directories. There are instructions on Technet.
        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: Forms authentication fails - login screen just refreshes

          All due respect I rebuilt all the OSA directories, if that's what you mean.

          Comment

          Working...
          X