No announcement yet.

"Send As" woes! - Exc07 SP3

  • Filter
  • Time
  • Show
Clear All
new posts

  • "Send As" woes! - Exc07 SP3

    So a user wants to "send as" a customer services mailbox but we keep getting bouncebacks.

    You are not allowed to send this message because you are trying to send on behalf of another sender without permission to do so. Please verify that you are sending on behalf of the correct sender, or ask your system administrator to help you get the required permission. 
    I've select the customer services mailbox and hit "Manage Send As Permission". Added the user and myself, yet we both get bounce backs when we try to send from: [email protected] in our outlook.

    I thought it might be because our exchange was SP1, a bug or something. I upgraded to SP3 last night but it has made no difference. The permissions were added days ago, so it's not a delay issue.

    Please help.

  • #2
    Re: "Send As" woes! - Exc07 SP3

    you need to give "send-on-behalf" permissions also

    Originally posted by

    Exchange Management Shell (EMS)
    The first method is to grant a specific user the ability to SendAs as another user. It consists of running only the following command and you are finished. The command is as follows:

    Add-ADPermission UserMailbox -ExtendedRights Send-As -user UserWhoSends
    err.. but use send-onbehalf
    Please do show your appreciation to those who assist you by leaving Rep Point


    • #3
      Re: "Send As" woes! - Exc07 SP3

      I had this same error once upon a time, and my resolution was:

      Exchange Management Console > Recipient Configuration > Mailbox > user > right click properties > Mail Flow Settings > Delivery Options > Properties > check user listed in the 'send on behalf' 'Grant this user permission to:

      After I added the user in there everything was peachy.
      Please remember to award reputation points if you have received good advice.
      I do tend to think 'outside the box' so others may not always share the same views.

      MCITP -W7,
      MCSA+Messaging, CCENT, ICND2 slowly getting around to.


      • #4
        Re: "Send As" woes! - Exc07 SP3

        I had that one recently, and if the right permissions are already assigned it usually points to a corrupt NK2 file on the sending client.

        I usually use powershell to assign the permissions, rather than EMC or ADUC. Seems to be the preferred method in 2K7 and higher.
        BSc, MCSA: Server 2008, MCSE, MCSA: Messaging, MCTS
        Cruachan's Blog