Announcement

Collapse
No announcement yet.

Exchange 2007 unable to send or recieve past the Mail Relay

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange 2007 unable to send or recieve past the Mail Relay

    Hi, need your help please.

    Current mail configuration is Exchange 2000 on server 2003. Mail is sent via a 2003 Mail Relay server sitting in the DMZ and not on the Domain.

    Have installed Exchange 2007 on to Server 2008 R2.
    Have configured the Hub Transport application with the appropriate inbound and outbound connectors both going to the mail-relay sever.
    The mail relay server has an inbound ip and a separate outbound ip.

    Have moved 2 mailboxes from the old server to the new server.

    I am able to send email from one pc to another on the new server.
    I am unable to send email out past the new exchange server.

    Any suggestions on this would be massively appreciated

  • #2
    Re: Exchange 2007 unable to send or recieve past the Mail Relay

    First test would be to telnet your mail relay at port 25 from your new Exchange 2007 server and the second test if you are able to successful relay a message through it.

    In the queue viewer of your Exchange 2007 you should see which status sent mails have, maybe this gives you a clue whats going wrong.

    In order to receive mails at your Exchange 2007 the relay have to be configured properly. Since you haven't mentioned any config changes at the relay you have to make sure that the connector for incoming mails points to your Exchange 2007 server.

    Comment


    • #3
      Re: Exchange 2007 unable to send or recieve past the Mail Relay

      It seems I am unable to telnet. Will look into this and update later. Thnx for the suggestion

      Comment


      • #4
        Re: Exchange 2007 unable to send or recieve past the Mail Relay

        If you can't telnet it could be a few things. Do you have firewall rules that only allow the original Exchange 2000 server to connect to the relay? Alternatively the 2003 relay could have an IP allow list on the SMTP connector so have a look there.

        Comment


        • #5
          Re: Exchange 2007 unable to send or recieve past the Mail Relay

          Okay, Problem solved.
          It was the McAfee AntiVirus vers.8.7 that was causing the problem.
          In the Access Protection Properties in the console, there is a setting called Anti-Virus Protection on the list.
          When you click on it, the enabled functions list is shown on the right.
          There is one called Prevent mass mailing worms from sending mails.
          I unticked this and was able to send out emails.
          Will check this evening after office hours if I can recieve emails from outside but I need to change the mail-relay server to point to the E2K7 first. If theres any probs, I will post.

          Thanks again for all the help

          Comment


          • #6
            Re: Exchange 2007 unable to send or recieve past the Mail Relay

            Thats a default setting with the McAfee AV. If you are using an EPO server you can create a policy for the relavent servers that need to relay on 25 to turn that setting off.

            Comment


            • #7
              Re: Exchange 2007 unable to send or recieve past the Mail Relay

              One more question please. I have no issues sending out as I have already said. However, to recieve, I am having to set the Permission Groups on the recieve connector to allow Anonymous users.
              Is this correct bearing in mind that I am using a mail relay to direct my email

              Comment


              • #8
                Re: Exchange 2007 unable to send or recieve past the Mail Relay

                Absolutely. Mail submission by default uses anonymous permissions to authenticate. Either that or you ask your smart host to configure a specific account to authenticate against your mail server with. That though is an administrative over head. If you want to beef up your security lock down the mail server with an ACL that only allow's the upstream mail server to communicate with the IP address of your mail server. Thus your public facing hub transport will only respond to SMTP from the upstream mail server.

                Comment


                • #9
                  Re: Exchange 2007 unable to send or recieve past the Mail Relay

                  So what I have done is change the remote network subnet so that it doesnt allow all IP addresses (0.0.0.0 to 255.255.255.255) but only the single inbound facing IP address of the mail relay.
                  And I have left the annonymous setting active.

                  Comment


                  • #10
                    Re: Exchange 2007 unable to send or recieve past the Mail Relay

                    Originally posted by sensei1973 View Post
                    So what I have done is change the remote network subnet so that it doesnt allow all IP addresses (0.0.0.0 to 255.255.255.255) but only the single inbound facing IP address of the mail relay.
                    And I have left the annonymous setting active.
                    That works too.

                    Comment


                    • #11
                      Re: Exchange 2007 unable to send or recieve past the Mail Relay

                      Excellent. Thanks for your help and suggestions. Really appreciate it.

                      Comment


                      • #12
                        Re: Exchange 2007 unable to send or recieve past the Mail Relay

                        Major problem.
                        Those who are using Outlook 2003 are having problems. It is taking a long time to send or recieve or are even crashing where as those of us who are using Outlook 2007 are having no problems. Any ideas?

                        Comment


                        • #13
                          Re: Exchange 2007 unable to send or recieve past the Mail Relay

                          This is a rather vague error description, could you be more specific?

                          Comment


                          • #14
                            Re: Exchange 2007 unable to send or recieve past the Mail Relay

                            It seems Outlook 2003 does not automatically connect to the new server unlike Outlook 2007.
                            Outlook2003 also will not allow you to manually change it. Therefore, we have had to create new profiles for the Outlook 2003 users and this seems to have solved the problem.
                            The initial connection does take a while as it is still synchronising with the new Exchange 2007 server but the issue is solved.

                            Comment


                            • #15
                              Re: Exchange 2007 unable to send or recieve past the Mail Relay

                              You can normally change the server in 2003, you just have to do it from the mail icon in the control panel whilst Outlook is not running. I'd imagine that 2003 doesn't benefit from autodiscover hence not automatically changing. In SBS they get changed for you but presumably not when you're not using SBS.

                              Comment

                              Working...
                              X