Announcement

Collapse
No announcement yet.

421 4.4.2 Errors : Mails stuck in queue.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 421 4.4.2 Errors : Mails stuck in queue.

    Hello I have an Exchange 2010 setup. I noticed just today that I mails have been residing in the queue for long. These were queued mails for yahoo, hotmail, gmail and others.

    When I checked the Error I was having :

    451 4.4.0 Primary target IP address responded with:

    "421 4.4.2 COnnection dropped due to Socket Error." Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts.
    Upon a few researches, suggestions were to find out if the server was on a Block List, or to check my DNS.

    I have checked my DNS forwarders and everything seems fine. I have also checked out the NAT IP of the mail server at spamhaus.org and its not on their Blocked List too. I have tried to create a custom send connector to those domains and still the queues still persist.

    Is there another way around this issue?.

    Thanks

  • #2
    Re: 421 4.4.2 Errors : Mails stuck in queue.

    It definitely sounds like a blacklist issue somewhere.

    Does your public IP addres have a reverse hostname? Do they match?
    (ie, 217.123.45.6 resolves to mail.company.com and mail.company.com resolves to 217.123.45.6)
    Last edited by tehcamel; 28th March 2011, 20:27.
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

    Comment


    • #3
      Re: 421 4.4.2 Errors : Mails stuck in queue.

      When I do an nslookup for the public IP I get:

      *** google-public-dns-a.google.com can't find x.x.x.x : Non-existent domain

      That definitely means the public IP is not resolving to the hostname of the server.
      But the strange thing is I am able to hit OWA from the internet browser when I use the public IP ie, https://public_IP/owa.

      What can be done to correct this issue. I have read a lot of post of removing public IPs from the spam block list but it sounds a tedious affair.

      One other issue is that, I have a UTM on the network which has an antivirus module, can it be that a malicious program was sending out SPAM emails from my domain without the UTM detecting it?.

      Also Open Relay too aint enabled on my server when I telnet into it, so how come my IP address has been blacklisted? Thanks.

      Comment


      • #4
        Re: 421 4.4.2 Errors : Mails stuck in queue.

        speak to your isp, and make sure your PTR record matches
        Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

        Comment

        Working...
        X