Announcement

Collapse
No announcement yet.

Exch 2010 - Outlook clients crash regularly.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exch 2010 - Outlook clients crash regularly.

    Hi,
    I'm having problems with an increasing number of Outlook clients, both 2007 & 2010, crashing at random intervals. Usually after doing something like sending an email, and often causing outlook to crash on every start of itself until the system is rebooted.
    Now ive tried a hundred different fixes for Outlook, from recreating profiles, to reducing extra mailboxes, removing/shrinking PSTs, reducing the number of items in a folder, removing outlook addins, using the /safe mode to test in that, using /cleanviews to clear out views. Removing outlook completely and reinstalling. And far more that i cant remember at the moment.

    This is basically becoming a larger and larger problem for the users, and i need to know why its happening and how to fix it.
    Now its started happening with my Outlook the last day or so, and one thing ive noticed, is that the tray app doesn't crash, and if i open the 'connection status' part of it, and wack 'reconnect' 10-15 times, that Outlook 50% of the time recovers itself.
    Now this would seem to me to be a connectivity issue to Exchange.

    Now i refuse to believe that its because the hardware/VMs that host exchange arnt up to the task. As if a barely running, massively underspec'd Exchange 2003 server could cope with the strains of running the companies communications, then the new setup should be fine.
    However im not removing a problem with the server configuration out of the equation.

    The 2010 setup is about 2-3 weeks old now, and apart from a "CAS array that's not an array", there's nothing special about how its been setup.

    Is there anything i can do/try to help solve these problems?

    Thanks in advance all.

  • #2
    Re: Exch 2010 - Outlook clients crash regularly.

    Question:
    Bit of a long shot, but it was suggested when i installed Exch2010 that i setup a CAS array without actually having the array there, to make future migrations easier.
    I basically did the entire process except install the NLB parts of it. Does that need to be done but only have our single CAS server in it?
    Just wondering if that could be the cause of the problem, as sometimes it does appear like clients lose connection to Exch, or struggle to connect.
    Thanks.

    Comment


    • #3
      Re: Exch 2010 - Outlook clients crash regularly.

      Ive just made a test database, moved my mailbox to it and set it to use the CAS server rarther than the CAS array, touch wood, it seems to be ok thus far.

      Anyone here think that this CAS array we've setup could be the issue?

      Thanks.

      Comment


      • #4
        Re: Exch 2010 - Outlook clients crash regularly.

        Are these laptops? Do you have Bluetooth enabled? Send to Bluetooth crashes Office 2010 and 2007 Office apps and Visio. I have to turn this COM addin off and remove from each.

        Comment


        • #5
          Re: Exch 2010 - Outlook clients crash regularly.

          Laptops and desktops, doesn't appear to be Bluetooth related as only one of the affected systems has Bluetooth, mine.
          Gonna test more on Monday, but based on observations late on Friday, its looking like a problem with the CAS array because as soon as a server request is canceled from the tray app, outlook responds again. It it hasn't affected my system now ive set the mailbox to go strait to the CAS server, touch wood.

          Comment


          • #6
            Re: Exch 2010 - Outlook clients crash regularly.

            After some faffing around I've concluded that the problem is the mailbox server, because
            MSExchageIS has an average RPC latency of 700-1000
            And
            MSExchahgeIS Client has a latency of 8000-9000

            Every other metric like queue length, processor time, LDAP response time, etc; is perfectly fine.

            Does anyone know of any methods to track down why the RPC is so high?

            Thanks.

            Comment


            • #7
              Re: Exch 2010 - Outlook clients crash regularly.

              This is worth a review.

              http://www.msexchange.org/articles_t...010-part1.html

              You should also anaylyse traffic between the server with the CAS role and the mailbox server role. Outlook clients in Exchange 200 connect to the CAS role holder.

              Ensure that the Outlook clients are pointed at the CAS role holder.

              Comment


              • #8
                Re: Exch 2010 - Outlook clients crash regularly.

                Originally posted by Virtual View Post
                This is worth a review.

                http://www.msexchange.org/articles_t...010-part1.html

                You should also anaylyse traffic between the server with the CAS role and the mailbox server role. Outlook clients in Exchange 200 connect to the CAS role holder.

                Ensure that the Outlook clients are pointed at the CAS role holder.
                They are pointed to the CAS Role holder, what's strange is, that if i look at the connection status on a machine that does have the problem, like mine, the directory, & public folder connections have an avg response time of under 10, where as the two mail connections are at 20,000+.

                The problem is definitely with the mailbox server, but as the RPC requests is quite low (10-30), its making me think that 1-2 clients are what's causing the problem for the entire system.
                Problem is nailing it down to a specific program or protocol or user.

                Comment


                • #9
                  Re: Exch 2010 - Outlook clients crash regularly.

                  Well using the troubleshooting assistant, its identified 9 users who have high latency MAPI operations. Unfortunately that's not alot of use to me, as im one of those users and I've done nack all in Outlook all day! So what's generating the requests!

                  Comment


                  • #10
                    Re: Exch 2010 - Outlook clients crash regularly.

                    Hi!

                    Also check antivirus software, there may be some influence on RPC times...

                    Comment


                    • #11
                      Re: Exch 2010 - Outlook clients crash regularly.

                      Already tried that. Disabled server side and client side.
                      No effect.

                      Its just very strange that the problem is with less than 10 users (who are getting the outlook crashes), and the only different for other people is that mail takes longer to get to places.

                      Comment


                      • #12
                        Re: Exch 2010 - Outlook clients crash regularly.

                        Has the Exchange server had a restart?

                        Comment


                        • #13
                          Re: Exch 2010 - Outlook clients crash regularly.

                          Yes.
                          At various points after trying various 'fixes'.

                          I am well and truly stumped .

                          Comment


                          • #14
                            Re: Exch 2010 - Outlook clients crash regularly.

                            Originally posted by boomam View Post
                            Already tried that. Disabled server side and client side.
                            No effect.

                            Its just very strange that the problem is with less than 10 users (who are getting the outlook crashes), and the only different for other people is that mail takes longer to get to places.
                            Try to uninstall AV software and restart server.
                            Sometimes disabling AV does NOT completly disable it

                            Comment


                            • #15
                              Re: Exch 2010 - Outlook clients crash regularly.

                              Originally posted by gregaSLO View Post
                              Try to uninstall AV software and restart server.
                              Sometimes disabling AV does NOT completly disable it
                              I know, there's also registry keys and a restart of the information store service. :-p
                              MS are looking into it now and are just as stumped as i am.
                              Been asked to install Outlook directly on the mailbox server to test, have done, same problem.
                              So they are now getting senior engineers involved now.
                              Least i know it wasn't through my own incompetence as the support engineer whos a 'Exchange Expert' did the same stuff i did! lol.

                              Comment

                              Working...
                              X