Announcement

Collapse
No announcement yet.

How to defeat "setup /preparead" FAIL?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to defeat "setup /preparead" FAIL?

    I'm trying to ready a 32-bit 2003-SP2 Forest with four domain controllers with two domains.

    I've got the 32-bit Exchange2007-SP2 "setup" and am trying "setup /preparead" but it fails.
    There is nothing obvious in EventLog. The Exchange Setup Log posts this:

    Code:
    # Default Install steps for ExchangeOrganization. 
    # Programmatically generated on 1/24/2011 2:29:41 PM. 
     
    # 
    # Variable Declarations 
    # 
    $RolePrepareOrganization = $True 
    $RoleProductPlatform = "i386" 
    $RoleUpdateResourcePropertySchema = $False 
    $RoleSchemaPrefix = "PostExchange2003_" 
    $RoleResourcePropertySchemaSaveFile = "C:\ExchangeSetupLogs\ResourcePropertySchema.xml" 
    $RoleOrganizationName = "myOrganization" 
    $RolePrepareDomain = $True 
    $RoleDomainController = "myServer.myDomain.com" 
    $RoleOrgConfigVersion = "11222" 
    $RolePrepareSchema = $True 
    $RoleFullyQualifiedDomainName = "myDomain.com" 
    $RolePrepareAllDomains = $False 
    $RoleInvocationID = "20110124-1429410802" 
    $RolePrepareLegacyExchangePermissions = $True 
    $RoleInstallationMode = "BuildToBuildUpgrade" 
     
    # 
    # Component tasks 
    # 
     
    # Tasks for 'Legacy Global AD Configuration' component 
    # [ID = 5c83d8d0, Wt = 1, isFatal = True] "Preparing the legacy forest." 
    if ($RoleDomain -ne $null) { initialize-ExchangeLegacyPermissions -Domain $RoleDomain -DomainController $RoleDomainController; } else { initialize-ExchangeLegacyPermissions -AllDomains:$true -DomainController $RoleDomainController; } 
     
    # Tasks for 'Resource Property Schema Component' component 
    # [ID = e08cce30, Wt = 1, isFatal = True] "Updating the resource property schema." 
    if($RoleUpdateResourcePropertySchema -and !(test-path $RoleResourcePropertySchemaSaveFile)) { get-resourceconfig -DomainController $RoleDomainController | export-clixml $RoleResourcePropertySchemaSaveFile } 
    # [ID = 9aa173e8, Wt = 1, isFatal = True] "Updating the resource property schema." 
    if($RoleUpdateResourcePropertySchema) { set-resourceconfig -ResourcePropertySchema $null -DomainController $RoleDomainController } 
    # [ID = 5410b2a1, Wt = 1, isFatal = True] "Importing resource property schema." 
    if($RoleUpdateResourcePropertySchema) { Install-ExchangeSchema -LdapFileName ($roleInstallPath + "Setup\Data\update_ResourcePropertySchema.ldf") } 
    # [ID = 23282e01, Wt = 1, isFatal = True] "Updating the resource property schema." 
    if(test-path $RoleResourcePropertySchemaSaveFile) { $value = import-clixml $RoleResourcePropertySchemaSaveFile; set-resourceconfig -resourcepropertyschema $value.ResourcePropertySchema -DomainController $RoleDomainController } 
    # [ID = c5bae993, Wt = 1, isFatal = True] "Updating the resource property schema." 
    Remove-SetupFile -FilePath $RoleResourcePropertySchemaSaveFile 
     
    # Tasks for 'Active Directory Schema' component 
    # [ID = bb99000e, Wt = 1, isFatal = True] "Importing Active Directory schema." 
    install-ExchangeSchema -LdapFileName ($roleInstallPath + "Setup\Data\"+$RoleSchemaPrefix + "schema0.ldf")
    I acquired 32-bit adprep.exe from Server 2008 media am able to run "adprep /forestprep" then after replication "adprep /domainprep" at each domain master with no errors.

    And looking at this URL:

    http://technet.microsoft.com/en-us/l...8WS.10%29.aspx

    Wt=1 means "failure" but what is the root cause?

    Any ideas?
    Last edited by chip743; 27th January 2011, 21:22.

  • #2
    Re: How to defeat "setup /preparead" FAIL?

    Exchange ADPrep is nothing to do with Server ADPrep -- you will need to run from the Exchange media
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: How to defeat "setup /preparead" FAIL?

      Originally posted by Ossian View Post
      Exchange ADPrep is nothing to do with Server ADPrep -- you will need to run from the Exchange media
      I ran server adprep just to confirm I was "enough of an admiistrator" permissions-wise to get the job done. I am running "setup /PrepareAD" from Exchange 2007 32-bit media.

      Comment


      • #4
        Re: How to defeat "setup /preparead" FAIL?

        Sorry -- got confused by the last bit of your first post which suggested you were confusing the two -- your later post makes it clear

        Anything in the event logs?

        Double check you meet ALL the prerequisites here:
        http://www.msexchange.org/tutorials/...007-Part1.html
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd
        Scotland

        ** Remember to give credit where credit is due and leave reputation points where appropriate **

        Comment


        • #5
          Re: How to defeat "setup /preparead" FAIL?

          Solved!

          The 32-bit Exchange2007-SP2 download got corrupted when extracting. Re-downloaded and unpacked and installed. Everything "completed" successfully.

          Comment

          Working...
          X