Announcement

Collapse
No announcement yet.

Time Sync problem on Exchange

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Time Sync problem on Exchange

    Hello everyone, i'm having a problem with my time sync on exchange 2010 and can't solve it.

    - i have Two DC's and Two Exchanges 2010 in replication.

    my problem is that - the exchange is time synchronizing with the DC2 and not with the DC1 and the DC2 is 6 minutes ahead for some reason of the DC1 . which is causing me troubles with sending and recieving emails.


    any idea someone ?

    p.s : everytime i chane the time on the DC2 back to normal it's happening again a few minutes later.

    thanks for the help.

  • #2
    Re: Time Sync problem on Exchange

    Where are the FSMO roles located?

    Comment


    • #3
      Re: Time Sync problem on Exchange

      The problem isn't with Exchange, it's with your DC's. You need to fix the time sync problem between the DC's.

      Comment


      • #4
        Re: Time Sync problem on Exchange

        Originally posted by aelekx View Post
        Hello everyone, i'm having a problem with my time sync on exchange 2010 and can't solve it.

        - i have Two DC's and Two Exchanges 2010 in replication.

        my problem is that - the exchange is time synchronizing with the DC2 and not with the DC1 and the DC2 is 6 minutes ahead for some reason of the DC1 . which is causing me troubles with sending and recieving emails.


        any idea someone ?

        p.s : everytime i chane the time on the DC2 back to normal it's happening again a few minutes later.

        thanks for the help.
        Yes - fix the time synchronisation between dcs, like joeqwerty stated.


        Are perhaps one or more of these servers virtual machines - And sync time with the host? When a VM currently is synchronising time with the host, the 'Windows Time' Service on that guest should not be enabled.

        Check also the registry values in
        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\W32Time\parameters
        - and here if configured by GPO;
        HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\W32 time\parameters
        The DC holding the PDCe role should never configured with type: NT5DS, and all other DCs/members/clients should.


        \Rems
        Last edited by Rems; 11th January 2011, 13:15.

        This posting is provided "AS IS" with no warranties, and confers no rights.

        __________________

        ** Remember to give credit where credit's due **
        and leave Reputation Points for meaningful posts

        Comment


        • #5
          Re: Time Sync problem on Exchange

          As a quick solution, run the following as a scheduled script on all servers:

          net time \\dc1 /set /y
          (replace dc1 with the appropriate name)

          Does not replace dealing with the problem but at least gets them in sync

          Oh, check your client clocks too
          Tom Jones
          MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
          PhD, MSc, FIAP, MIITT
          IT Trainer / Consultant
          Ossian Ltd
          Scotland

          ** Remember to give credit where credit is due and leave reputation points where appropriate **

          Comment

          Working...
          X