Announcement

Collapse
No announcement yet.

OAB & Autodiscover issue in exchange 2010

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OAB & Autodiscover issue in exchange 2010

    Hi,

    Recently migrated from sbs 2003 to windows 2008 r2 dc & exchange 2010 on windows 2008 r2 member server. The mailbox transfer went fine.
    SSL cert was also purchased for :
    exch.domain.local
    autodiscover.exch.domain.local
    owa.domain.com.au
    autodiscover.domain.com.au

    But when I connect outlook 2007 client to exchange 2010, it gives two errors:
    1. A certificate security alert for autodiscover.domain.com.au:
    The name on the security certificate is invalid or doesnot match the name of the site. When I click on view certificate, it comes up with self signed certificate.
    2. Microsoft Exchange offline address book error:
    Not downloading Offline address book files. A server (URL) could not be located. 0X8004010F

    I created newOAB & set as default & setup NewOAB for the database up in EMC but still the same OAB error.
    I installed both the certificates (Self signed & purchased SSL) on client computer (not a part of domain) but still ssl alert still comes up.

    These errors only appears on machines that are not connected to domain.

    Thanks in anticipation,

    BRS

  • #2
    Re: OAB & Autodiscover issue in exchange 2010

    You didn't need the internal name on autodiscover.
    Autodiscover uses the email address of the user, and adds autodiscover to the domain after the @ sign. So if a user is [email protected] then Outlook will try and use autodiscover.example.com

    How did you install the certificate on the server? Have you bound it to the relevant services? Installing the certificate on to the local machine should not be required and defeats the point of having a commercial certificate.

    The second error means cannot find, and could well be related to the SSL certificate issue. It also depends on what distribution methods you are using for the OAB. If you have public folders enabled but do not have a public folder store, then that can generate the error that you are seeing.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: OAB & Autodiscover issue in exchange 2010

      Thanks Sembee for the reply.

      The SSL cert is bound to the relevant services. I have also successfully connected outlook exchange account from remote pc to the Exchange server without installing the SSL cert on remote pc.

      The distribution method I am using is Web based bcz all connecting outlooks are 2007/2010. The OAB, public folder store, all are there.

      The SSL cert alert doesnot come when connecting outlook remotely to exchange. The alert also doesn't showup for domain joined workstations. The alert basically comes up for non-domain laptops that are connected to local LAN. The OAB issue is still the same.

      Thanks in anticipation,

      BRS

      Comment


      • #4
        Re: OAB & Autodiscover issue in exchange 2010

        Have you removed the self signed certificate, so it is not listed inside Exchange 2010?
        The fact that it only occurs for non-domain machines would tend to point to autodiscover. If you have machines that are on your LAN, using your Exchange server, then you need to ensure that autodiscover.example.com resolves internally to your internal IP address - usually by using split DNS.

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment

        Working...
        X