No announcement yet.

OWA 2010 - Options won't work & Can't Setup ActiveSync (ForeFront)

  • Filter
  • Time
  • Show
Clear All
new posts

  • OWA 2010 - Options won't work & Can't Setup ActiveSync (ForeFront)

    Hi all,

    Recently, I installed ForeFront TMG Enterprise 2010 and Exchange 2010 for our small school. Largely, it's all working fine. I have a couple items that I've been working on for a while, but I just can't seem to get 'em working...

    1. The "Options" button when in OWA. When clicked on, what happens is that I am taken to the login screen again. Upon logging in (again), the page doesn't come up. Basically, there's nothing there at all. Happens in IE and FF. But here's the weirdest part. If I access OWA from my Droid phone, Options WORKS! Huh??

    2. ActiveSync. Argh! I don't know what I'm doing wrong, but I cannot get this working... I have everything setup and, I believe, functional in Exchange. And I followed this article to the letter to publish ActiveSync through FF. The Rule tests good, but I cannot get it loaded on my phone (Motorola Droid). I've since done some tweaking all to no avail. Personally, I'm willing to start from scratch.

    Can someone please help me get these two things working? That would really make my day... Thanks!


  • #2
    Re: OWA 2010 - Options won't work & Can't Setup ActiveSync (ForeFront)

    Your first problem seems like related to the Exchange Control Panel web site, what happens if you type directly /ecp instead of /owa?

    The article you followed to publish ActiveSync seems like written by a ISA/TMG guy rather then a Exchange guy, he wants you to change the authentication on the default web site, this might work, but there is a site for ActiveSync only, so the authentication have to be correct on this one. You can check through powershell "Get-ActiveSyncVirtualDirectory | fl" whether BasicAuth is enabled or not.
    Second idea comes into places if you are using Exchange 2010 SP1, I had trouble to get ActiveSync devices working while using the default Active Sync policy, after some digging someone mentioned to create a new ActiveSync policy and use this ... worked in this case.


    • #3
      Re: OWA 2010 - Options won't work & Can't Setup ActiveSync (ForeFront)

      Hi, and thanks for the reply!

      We'll start with OWA Options. I replaced owa with ecp in the URL, and after logging in, it went to the blank page like it does when I click on Options through the OWA page.

      What's the fix? Driving me nuts... LOL!




      • #4
        Re: OWA 2010 - Options won't work & Can't Setup ActiveSync (ForeFront)

        Wait a tic! I got it!

        I had to set authentication to Basic in IIS at:

        IIS Manager > Sites > Default Web Site > ecp > Authentication

        Did that, restarted IIS, and it's Miller Time!

        Now how's about that ActiveSync? I think I'm just gonna start over with that one. Can you help me get that going? What do I have to check in Exchange, first of all. Then, how do I setup FF to let it in?



        • #5
          Re: OWA 2010 - Options won't work & Can't Setup ActiveSync (ForeFront)

          Ah, I think your initial problem was the article related to publishing ActiveSync with TMG, since you have set the default site to basic.

          I would basicly advice you to set authenticiation for Exchange sites exclsuive using Exchange Management Console or Powershell.

          I think you have to go with basic authentication for ActiveSync as set in TMG. First of all look with
          "Get-ActiveSyncVirtualDirectory | fl"
          what your current settings are then enable basic authenticiation if needed and look if this works.


          • #6
            Re: OWA 2010 - Options won't work & Can't Setup ActiveSync (ForeFront)

            Hi again,

            This is probably a dumb question, but how do I run the command:

            Get-ActiveSyncVirtualDirectory | fl

            In a simple CMD prompt on the Exchange server?

            [edit] NEVERMIND, I figured it out... Exchange Management Shell... Basic Auth IS enabled: Set to True. [/edit]
            Last edited by WorldBuilder; 10th November 2010, 17:04.


            • #7
              Re: OWA 2010 - Options won't work & Can't Setup ActiveSync (ForeFront)


              OK, I started over with the whole ActiveSync thing because I was so twisted I didn't know which end was up. And I found a good TechNet article to follow: Here it is. At any rate, I still cannot get this working, and I wanted to run a few things by you to see if you can tell me what I've done wrong. Remember, I am NOT an expert with this stuff. It's all very new to me.

              I successfully created the Web Listener as outlined in Steps 1-4 of that article. Worked fine.

              I then proceeded to create the Access Rule.

              Everything is pretty straightforward until I get to the "Internal Site Name". For that, I typed "https://lfdcs-mail.lfdcs.lan/Microso...ver-ActiveSync". That is what's listed as the "Internal URL" when I go to EMC > Server Configuration > Client Access > Exchange ActiveSync Tab > General. I left the "Use a computer name or IP address to connect to the published server" box unchecked. Is that right?

              Next was the "Public Name". I put in, but I'm not really sure what it wants here. Does it want instead? Does it want the external IP address?

              Next is the selection of the Web Listener. Well, I select the ActiveSync Listener I created above, and I get the following error:
              A Web listener specifying the same port and similar IP addresses is already in use by rule "Publish OWA". The port and IP addresses specified in a Web listener cannot overlap with the IP addresses and ports specified in another Web listener already used in a different rule.
              OK, well since it won't let me do that, I simply select the OWA Listener I created for OWA. Actually, the two listeners DO have the same exact settings... Is using the OWA Listener OK? Or does this rule need its own listener? If so, could I simply change the port the "ActiveSync Listener" uses, and if so, what port would you recommend?

              I finish the wizard using the settings from that article (Basic Authentication, All Authenticated Users, etc...)

              I apply it all in ForeFront. Then I open the Rule Properties, click Test Rule, and get the errors you see in the attached screenshot. It seems that I have a name resolution problem... Grrrrrrr...

              Is it a misconfiguration that I mention above? Can you see what's wrong? Let's start with that and see what happens.

              Thanks a million, I really appreciate all your help.

              Attached Files


              • #8
                Re: OWA 2010 - Options won't work & Can't Setup ActiveSync (ForeFront)

                Is OWA working? The ActiveSync, OWA and Outlook Anywhere external URLs are normally all the same and use both the same IP address and Web Listener. However you should always use the wizards for creating Exchange publishing rules, and best practice is to have a seperate rule for each service you publish.

                For simplicity I usually use the same name internally and externally, with a hosts file resolving the external name to the internal IP on the TMG Server. This is to allow things like the same OWA experience for internal and external users, and saves creating a second certificate with the internal names for full SSL connectivity between the TMG and Exchange servers, rather than bridging via HTTP.

                This article may help as it specifically talks about ISA/TMG and Exchange publishing. There is also an MS blog and white paper.
                BSc, MCSA: Server 2008, MCSE, MCSA: Messaging, MCTS
                Cruachan's Blog


                • #9
                  Re: OWA 2010 - Options won't work & Can't Setup ActiveSync (ForeFront)

                  Hi Cruachan,

                  Yeah, OWA works perfectly fine. Good advice. I'll have a look at the article(s) and post back in a few days. Thanks!