No announcement yet.

2010 Mailbox role installation "couldn't find database"

  • Filter
  • Time
  • Show
Clear All
new posts

  • 2010 Mailbox role installation "couldn't find database"

    Hi all,

    A couple months ago I started upgrading the first half of my 2010 DAG setup to SP1. However, the upgrade failed somewhere. In an effort to fix things, I deleted the DAG (and the entire server that the non-upgraded half was on), and attempted the upgrade again, to no avail.

    So for a while I've been putting up with a single, working-but-half-upgraded server.

    I installed SP1 Update rollup 1 on the server last night, hoping it might fix things, but it didn't.

    I have no requirement to keep the existing server, so I can reinstall/setup new ones at will (they're all VMs), but I do need to keep all the users/computers in the AD domain and the Exchange mail/etc database. Public folders aren't used.
    I have tried to setup a new server a few times, but keep running into the same error that I get when trying the SP1 upgrader on the current server.
    I have pasted the error I keep getting below:

    Mailbox Role
    The following error was generated when "$error.Clear(); 
              if (!$RoleIsDatacenter)
                $mailboxId = [Microsoft.Exchange.Management.Deployment.UpdateRmsSharedIdentity]::SharedIdentityCommonName;
                $displayName = "Microsoft Exchange Federation Mailbox";
                $existingFederatedUserMailboxes = @(Get-Mailbox -Filter {Name -eq $mailboxId} -IgnoreDefaultScope -ResultSize 1);
                $existingFederatedArbitrationMailboxes = @(Get-Mailbox -Arbitration -Filter {Name -eq $mailboxId} -IgnoreDefaultScope -ResultSize 1);
                if (($existingFederatedUserMailboxes.Length -eq 0) -and ($existingFederatedArbitrationMailboxes.Length -eq 0))
                  $mailboxDatabase = @(get-MailboxDatabase -Server:$RoleFqdnOrName -DomainController $RoleDomainController);
                  if ($mailboxDatabase.Length -ne 0)
                    $mailboxUsers = @(Get-User -Filter {LastName -eq $mailboxId} -IgnoreDefaultScope -ResultSize 1);
                    if ($mailboxUsers.Length -ne 0)
                      $federatedMailbox = Enable-Mailbox -Arbitration -Identity $mailboxUsers[0] -Database $mailboxDatabase[0].Identity;
                      Set-Mailbox -Arbitration -Identity $federatedMailbox -RequireSenderAuthenticationEnabled $false -ProhibitSendReceiveQuota 1MB -ProhibitSendQuota 1MB -IssueWarningQuota 1MB -UseDatabaseQuotaDefaults $false -SCLDeleteEnabled $false -SCLJunkEnabled $false -SCLQuarantineEnabled $false -SCLRejectEnabled $false -HiddenFromAddressListsEnabled $true -DisplayName $displayName -Force;
                      Set-TransportConfig -OrganizationFederatedMailbox $federatedMailbox.WindowsEmailAddress.ToString();
            " was run: "Couldn't find database "MBDB-Leia\LEIA". Make sure you have typed it correctly.".
    Couldn't find database "MBDB-Leia\LEIA". Make sure you have typed it correctly.
    Click here for help... hxxp://
    Reading through the error message, it looks like there are still remnants of the DAG left somewhere in the AD schema/config, as it refers to "MBDB-Leia\LEIA" (I remember that when the DAG was operational, the servers were referred to as "MBDB-Leia\LEIA" and "MBDB-Leia\Winter" (the second server)).
    "MBDB-Leia" is the name of my database, and "LEIA" is the name of the DAG server I tried to upgrade to SP1 (now the only Exchange server left in the domain).

    I have looked through the domain schema and configuration using ADSI edit, and deleted all the DAG references I could find, but maybe there's something I missed?

    If anyone has any ideas how to fix this, I'm all ears!

    Thanks in advance,