Announcement

Collapse
No announcement yet.

error install exchange 2016

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • error install exchange 2016

    hi

    I install 10 time exchange 2016 and the same show : error in step 7 of the installion : mailbox role: transport service
    I don`t what to do ? I repeat the manual of the instalion sevral time and no success. what should I do ?

    :The following error was generated when "$error.Clear();

    $feVdirName = "PowerShell (Default Web Site)";

    $beVdirName = "PowerShell (Exchange Back End)";

    $vdirName = "PowerShell";

    $InternalPowerShellUrl="http://" + $RoleFqdnOrName + "/powershell";

    @

    $vdir = get-PowerShellVirtualDirectory -ShowMailboxVirtualDirectories -server $RoleFqdnOrName -DomainController $RoleDomainController | where { $_.Name -eq $beVdirName };

    if ($vdir -eq $null)

    {

    new-PowerShellVirtualDirectory $vdirName -Role Mailbox -DomainController $RoleDomainController -BasicAuthentication:$false -WindowsAuthentication:$true -RequireSSL:$true -WebSiteName "Exchange Back End" -Path ($RoleInstallPath + "ClientAccess\PowerShell-Proxy");

    }

    else

    {

    update-PowerShellVirtualDirectoryVersion -DomainController $RoleDomainController;

    }

    @

    $vdir2 = get-PowerShellVirtualDirectory -ShowMailboxVirtualDirectories -server $RoleFqdnOrName -DomainController $RoleDomainController | where { $_.Name -eq $feVdirName };

    if ($vdir2 -eq $null)

    {

    new-PowerShellVirtualDirectory $vdirName -Role Mailbox -InternalUrl $InternalPowerShellUrl -DomainController $RoleDomainController -BasicAuthentication:$false -WindowsAuthentication:$false -RequireSSL:$false -WebSiteName "Default Web Site" -AppPoolId "MSExchangePowerShellFrontEndAppPool";

    }

    else

    {

    update-PowerShellVirtualDirectoryVersion -DomainController $RoleDomainController;

    }

    " was run: "System.ArgumentException: The virtual directory 'PowerShell' already exists under 'ksexchange2007.ksdomain.co.il/Default Web Site'.

    Parameter name: VirtualDirectoryName

    at Microsoft.Exchange.Configuration.Tasks.Task.ThrowE rror(Exception exception, ErrorCategory errorCategory, Object target, String helpUrl)

    at Microsoft.Exchange.Management.SystemConfigurationT asks.NewExchangeVirtualDirectory`1.InternalValidat e()

    at Microsoft.Exchange.Configuration.Tasks.Task.<Proce ssRecord>b__c()

    at Microsoft.Exchange.Configuration.Tasks.Task.Invoke RetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)".

    @

  • #2
    Could we have some more information - what OS are you installing on? what roles does it already have? Are pre-requisites installed? What permissions does the account have?

    Have you tried re-downloading the install files (possibly corrupt)?

    From the error, the process has got part way, failed and then has existing objects to clean up. If you are not needing IIS for anything else, try removing the IIS role completely then re-adding (or letting the setup do it as part of the pre-reqs)
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment

    Working...
    X