Announcement

Collapse
No announcement yet.

Enabling SSL Cert - IIS issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Enabling SSL Cert - IIS issues

    Enabling SSL Cert has issue with enabling IIS :

    Enable-ExchangeCertificate : An unexpected error occurred while the forms-based authentication settings for path /LM/W3SVC/1 were being modif

  • #2
    Which version and service pack of Exchange?
    What process did you follow to request and install the certificate

    (As long as you do it all via Exchange, there should be no issues)
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Service Pack 2

      I did renew SSL Cert
      install it >>import it >>enable it with

      Enable-ExchangeCertificate -Thumbpring <string> -Services “SMTP, IMAP, POP, IIS
      i the error
      then i did this Enable-ExchangeCertificate -Thumbpring <string> -Services “SMTP, IMAP, POP, without IIS and worked without any error
      after that

      Enable-ExchangeCertificate -Thumbpring <string> -Services IIS
      I got the error

      Comment


      • #4
        (sigh) Yes, but which VERSION of Exchange? 2007, 2010,....
        Since you are doing it all in Powershell, I assume you are using 2007, but can you confirm that?

        Do you get any more information about the error?
        Have you checked the IIS logs (and the event logs)?
        Where are you generating the certificate request (and how)?
        Where is the certificate from?
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd
        Scotland

        ** Remember to give credit where credit is due and leave reputation points where appropriate **

        Comment


        • #5
          2007
          SSL cert from godady
          it was expire and i did renew it
          donload it >>import it >>enable it

          Comment


          • #6
            Because its Exchange (which can be fussy) I normally create a new certificate request rather than a renewal. You may want to try that.

            Also what about the event logs (and perhaps add a few more words to your answers - they don't actually cost anything)
            Tom Jones
            MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
            PhD, MSc, FIAP, MIITT
            IT Trainer / Consultant
            Ossian Ltd
            Scotland

            ** Remember to give credit where credit is due and leave reputation points where appropriate **

            Comment


            • #7
              Hello Ossian
              as you know when i did this comd Enable-ExchangeCertificate -Thumbpring <string> -Services IIS i got error (
              Enable-ExchangeCertificate : An unexpected error occurred while the forms-based authentication settings for path /LM/W3SVC/1 were being modif )

              to solve this i added the cert to IIS
              by this way iis manager >>Sites>>Defult Web Stie >> Binding >>https 443 >>link to FQN

              everything is ok
              Last edited by Hani Alhabshi; 20th April 2017, 11:34.

              Comment

              Working...
              X