Announcement

Collapse
No announcement yet.

Certificate issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Certificate issue

    Hello,

    The environment: Win 2012 r2 + exchange server 2016 (on same machine since it's small organization)
    The domain name I configured is : company.local
    There is a certificate from godaddy for autodiscover and mail.company.com that installed on the server. Exchange active sync, outlook anywhere works fine and there is no problem.

    My question is regaeding the mapi which configured in virtual direcotories with these url's:

    External URL: https://mail.company.com/mapi
    Internal URL: https://win2k12.company.local/mapi

    Since i can't add the alternetive name "win2k12.company.local" to godaddy certificate, the outlook clients which conecct internally get the certificate warning that win2k12.company.local isn't recognized and if i change the internal URL to "https://mail.company.com/mapi" like the external , the outlook client is disconnected from the server.
    I also noticed that the warning message appears on the stations that include shared mailbox..
    How should i solve this?


  • #2
    You will probably need to set up "split DNS" so company.com resolves internally to your local IP addresses as well as externally. Then you can change the internal URL to company.com
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Thanks Oossian..
      I created a new zone in DNS called mail.company.com , then created A record with the local server IP.
      I changed the mapi internal URL to https://mail.company.com/mapi, Now the outlook clients connect successfully without the warning message but i can't see in account properties the "connection" tab with the Outlook anywhere and exchange proxy setting. Since it's a laptop, i need to make sure it can connect also from outside the network. why i can't see it?
      Also the server name in outlook account properties: "https://mail.company.com/mapi/emsmdb/[email protected]" Is it normal?

      Comment

      Working...
      X