Announcement

Collapse
No announcement yet.

Email delay to one domain

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Email delay to one domain

    Hi
    I got delay sending to one of the domain.
    On the exchange queue, it showed 451 4.4.0 Primary target IP address responded with: "421 4.4.2 Unable to connect.
    Check the smtp log and the delay seem to be in my side.
    What should i do and check.

    See line 2
    Hop Delay From By Time (MST)
    1 * MAK 10.160.1.113 exch.pstechno.com.my 10.160.100.1 11/09/2016 16:51
    2 5 hour mail.my2.shm.com 17.x.x.140 relmlie1.idc. 11/09/2016 21:56
    3 24 seconds relmlie1.idc. 1x.23x.4.65 relmlac1.idc. 11/09/2016 21:57
    4 0 seconds relmlac1.idc. 127.0.0.1 relmlac1.idc. 11/09/2016 21:57
    5 0 seconds userid relmlac1.idc. 11/09/2016 21:57
    6 0 seconds relmlac1.idc. 1x.23x.69.21 relmlir1.idc. 11/09/2016 21:57
    7 * relmlir1.idc. 1x.23x.68.151 SMSSMTP 4.0.0.59 11/09/2016 21:54
    8 2 seconds 172.28.2.130 NECSEM-EXCHANGE.necsem.com.my 11/09/2016 21:54
    Attached Files

  • #2
    How is your email being delivered - direct to server or via a smart host?
    DOes it go eventually?
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Direct, no smart host in between.
      It does go eventually, hence the delay.
      Sender receive this bouce back
      **********************
      This message hasn't been delivered yet. Delivery will continue to be attempted.

      The server will keep trying to deliver this message for the next 1 days, 19 hours and 59 minutes. You'll be notified if the message can't be delivered by that time.
      **********************

      Comment


      • #4
        If it is only for one domain, it is as likely to be the other server not responding (off / connector is only for certain hours etc). Have you talked to their Exchange admins?
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd
        Scotland

        ** Remember to give credit where credit is due and leave reputation points where appropriate **

        Comment


        • #5
          Yes, their reply was
          ******
          It seems like the delay occurred when user tried to send from exch.pstechno.com.my to mail.my2.shm.com since there was no failed connection attempts from mail.my2.shm.com in our Japan mail server log.
          ******
          And the attached table, with highlighted line 2.

          I even try create Send Connector specifically to their IP address, also getting queue
          Attached Files

          Comment


          • #6
            i'm still cant resolve this issues.


            0

            i dont use SmartHost, it all direct to the DNS provider.

            is there any relation with SMTP port 25 or 587?

            because all the client is using port 587?

            also today we receive this

            ============================================

            Diagnostic information for administrators:<o></o>

            Generating server: MSHP01.000.com
            Receiving server: mail.000.com (210.000.000.170)
            Total retry attempts: 13

            user@rsm.000.com

            Remote Server at mail.000.com (210.000.000.170) returned '400 4.4.7 Message delayed'
            2/1/2017 11:23:52 AM - Remote Server at mail.000.com (210.000.000.170) returned '451 4.4.0 SMTPSEND.SuspiciousRemoteServerError; remote server disconnected abruptly; retry will be delayed'<o></o>

            =============================================

            Comment


            • #7
              587 is Exchange's internal port for email from Outlook Clients. All external email should use port 25 unless negotiated with an individual company and a special send connector created.
              From the message above, it looks as if their server is not talking to you, possibly because it thinks you generate spam. Do you have public SPF records?
              Tom Jones
              MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
              PhD, MSc, FIAP, MIITT
              IT Trainer / Consultant
              Ossian Ltd
              Scotland

              ** Remember to give credit where credit is due and leave reputation points where appropriate **

              Comment


              • #8
                i have reverse DNS
                But i check, we don't have SPF record


                Attached Files

                Comment


                • #9
                  i hv inform ISP to config the SPF record, and it look problem is resolved.

                  Comment


                  • #10
                    Well done, and thanks for reporting back!
                    Tom Jones
                    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
                    PhD, MSc, FIAP, MIITT
                    IT Trainer / Consultant
                    Ossian Ltd
                    Scotland

                    ** Remember to give credit where credit is due and leave reputation points where appropriate **

                    Comment

                    Working...
                    X