No announcement yet.

Edge Transport Role installed on Exchange 2016 server.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Edge Transport Role installed on Exchange 2016 server.

    Hi there,

    I'm hoping someone here will be able to help me. I have managed to install the Edge Transport role on an existing Exchange 2016 mailbox server (Windows 2012 R2,) and it seems to have heavily crippled the existing mailbox functionality there. Is it possible to remove the edge transport role without losing the mailbox data on the server, or otherwise get it functional again?
    I'm new to this forum, so please let me know if I need to provide any more information.



  • #2
    No experience of this configuration, but MS have said from the beginning that ET is incompatible with other roles.
    Worst case is cleanly uninstall the ET role and do a DR re-install of the MBX role as all the configuration should be in AD
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    IT Trainer / Consultant
    Ossian Ltd

    ** Remember to give credit where credit is due and leave reputation points where appropriate **


    • #3
      Thanks. It sounds like all is not lost, then, but I can't find a way to uninstall just the ET role or even all of them. If I run Setup.exe if tells me "Incomplete Installation Detected" and offers to try to complete it, but doesn't get past 0%.

      At the command line I get this:

      D:\>setup /m:uninstall

      Welcome to Microsoft Exchange Server 2016 Cumulative Update 1 Unattended Setup

      Mailbox role: Mailbox service
      Mailbox role: Unified Messaging service
      Mailbox role: Client Access service
      Mailbox role: Transport service
      Edge Transport Role
      Mailbox role: Front End Transport service
      Mailbox role: Client Access Front End service
      Management tools

      Performing Microsoft Exchange Server Prerequisite Check

      Configuring Prerequisites COMPLETED
      Prerequisite Analysis FAILED

      You must be a member of the 'Organization Management' role group or a member of
      the 'Enterprise Admins' group to continue.
      For more information, visit:

      Setup encountered a problem while validating the state of Active Directory:
      ADAM is installed on this machine; only the Microsoft Exchange Edge Transport
      server role may be installed. See the Exchange setup log for more information
      on this error.
      For more information, visit:

      Either Active Directory doesn't exist, or it can't be contacted.
      For more information, visit:

      The Exchange Server setup operation didn't complete. More details can be found
      in ExchangeSetup.log located in the <SystemDrive>:\ExchangeSetupLogs folder.

      I can see the installer has put AD LDS on the server, and this seems to be preventing the uninstall. Is it worth continuing to try to uninstall, or should I be spending my time setting up a new server to move the DB files to?