Announcement

Collapse
No announcement yet.

Exchange 2013 On premise set MessageRateLimit for User has no effect.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange 2013 On premise set MessageRateLimit for User has no effect.

    Hi

    Pulling my hair out over this one, have a small Exchange 2013 Box running hosted exchange for about 7 organizations. I need to set a MessageRateLimit for sending for one mailbox. I have used the following commands:-

    New-ThrottlingPolicy -Name UPLimitPerMinute -MessageRateLimit 2
    Set-Mailbox -Identity user_alias -ThrottlingPolicy UPLimitPerMinute

    both command execute without error, if I subsequently run the Set-Mailbox -Identity user_alias -ThrottlingPolicy UPLimitPerMinute it says that it has executed but no changes were made indicating the initial run of the command worked.

    If I run Get-ThrottlingPolicy UPLimitPerMinute |fl *limit* it shows :-

    MessageRateLimiit : 2
    RecipientRateLimit : Unlimited
    ForwardeeLimit : Unlimiited

    If I run :-

    GetThrottlingPolicyAssociation user_alias | select throttlingpolicyid

    ThrottlingPolicyId
    ------------------
    UPLimitPerMinute

    So all looks to be set correctly. I have restarted :- Transport Delivery, Transport Submission, RPC Client Access and Microsoft Exchange Throttling Services.

    However the rate is never applied, if I use VBA to send 200 message they arrive within 3 minutes, If I use Outlook, the limit is not honoured as quick as I can type they arrive, also the same behaviour in OWA.

    Any ideas as to why this is not working?


    Regards

    Matt

  • #2
    MessageRateLimit parameter is used to defer messages but it would not deny delivery , Messages are eventually delivered. You should set the RecipientLimit on the Mailbox.

    Regards,
    Fazal
    Fazal Zaidi
    MCITP-Windows 2008,Exchange 2010,MCTS-Exchange 2007,2010,Lync 2010,MCSE-2000,2003,MCSA-2003,2008,2012,MCP,MCSE -Messaging 2013,ITIL

    Comment


    • #3
      I am a little confused here surely Set-Mailbox -Identity user_alias -ThrottlingPolicy UPLimitPerMinute the 'user_alias' which I substitute with the true Mailbox Alias does exactly what you are saying in your reply.

      Comment

      Working...
      X