No announcement yet.

sbs 2008 owa stopped working

  • Filter
  • Time
  • Show
Clear All
new posts

  • sbs 2008 owa stopped working

    Hello Everyone,
    i had a SBS 2008 setup, where owa worked fine until i needed to install a new certificate because remote web workplace did not work for remote desktops. the public name of my domain is and a public record is so, through iis in sbs i requested a new domain certificate with a friendly name and then, after exporting the default sites certificate, i removed it from iis and went to bindings of the "sbs web applications" site to map the newly issued certificate for https requests of this site. that was it! owa stopped working. the odd thing is that /remote works fine. i tried removing owadirectory and recreating it through exchange management shell, but owa is still not working. when i hit /owa directory, the known page "There is a problem with this website's security certificate." appears, i click "Continue to this website (not recommended)." and then i am left waiting for the page to appear. i cannot display the login page. i would greatly appreciate any help. thanks in advance

  • #2
    Re: sbs 2008 owa stopped working

    You did it all wrong.

    There are two ways to get an SSL certificate on SBS.

    1. Through the wizard in the management console.
    2. Through Exchange.

    Using IIS for the certificate request is not correct for any scenario involving SBS and/or Exchange 2007.

    I have a blog posting on how to implement an SSL certificate with multiple names on SBS 2008 here:

    Simon Butler
    Exchange MVP

    More Exchange Content:
    Exchange Resources List:
    In the UK? Hire me:

    Sembee is a registered trademark, used here with permission.